Bug 34394

Summary: [GTK] Some input methods are misbehaving
Product: WebKit Reporter: Gustavo Noronha (kov) <gns>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: mrobinson
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
URL: http://bugs.debian.org/567335

Description Gustavo Noronha (kov) 2010-01-31 07:52:39 PST
From the Debian bug report:

On Thu, Jan 28, 2010 at 06:37:40AM -0800, Brian Marshall wrote:
[...]
> $ GTK_IM_MODULE=xim epiphany
> 
> Typing "debian" in any form field produces "ddeebbiiaann".
> 
> $ GTK_IM_MODULE= epiphany
> 
> Normal behavior. Typing "debian" in any form field produces "debian".
> 
> The same thing happens with Midori, but not Arora (which uses Qt). This
> only affects forms in web pages, not the browser UI (e.g., the location
> bar).

I can confirm this behaviour, though it doesn't happen with plain scim
(GTK_IM_MODULE=scim). It also leads to strange behaviour when using
advanced input methods in scim, such as anthy.

Mike
Comment 1 Gustavo Noronha (kov) 2010-02-02 04:25:55 PST

*** This bug has been marked as a duplicate of bug 32290 ***