Bug 33993

Summary: Use stale cache data when going back and forward but not using WebCore’s page cache
Product: WebKit Reporter: Maciej Stachowiak <mjs>
Component: New BugsAssignee: Adam Langley <agl>
Status: RESOLVED FIXED    
Severity: Normal CC: agl, ap
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Attachments:
Description Flags
Patch
none
Patch agl: review-

Description Maciej Stachowiak 2010-01-22 01:47:54 PST
Use stale cache data when going back and forward but not using WebCore’s page cache
Comment 1 Maciej Stachowiak 2010-01-22 02:27:33 PST
Created attachment 47184 [details]
Patch
Comment 2 Adam Roben (:aroben) 2010-01-22 08:04:08 PST
Comment on attachment 47184 [details]
Patch

The CachePolicy enum is a little confusing to me. I think the names of its members could be made clearer. But your new name seems OK.

r=me
Comment 3 Alexey Proskuryakov 2010-01-22 08:31:44 PST
See also (duplicate of?) bug 5344.
Comment 4 Maciej Stachowiak 2010-01-22 16:43:52 PST
Committed r53737: <http://trac.webkit.org/changeset/53737>
Comment 5 Adam Langley 2011-06-28 07:48:26 PDT
Created attachment 98919 [details]
Patch