Bug 33973

Summary: plugins/mouse-events and plugins/mouse-events-fixedpos don't fire events on the plugin
Product: WebKit Reporter: Brian Weinstein <bweinstein>
Component: Plug-insAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: aroben, jberlin, noel.gordon, simon.fraser
Priority: P2 Keywords: InRadar, PlatformOnly, Regression
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows 7   
Bug Depends on: 62375    
Bug Blocks:    

Description Brian Weinstein 2010-01-21 14:56:45 PST
plugins/mouse-events and plugins/mouse-events-fixedpos don't fire events on the plugin.

The output that is given on Mac that is missing on Windows is:

CONSOLE MESSAGE: line 0: PLUGIN: getFocusEvent
...

No events on the plugin are fired to us. Adam Roben said this could be because we send the events directly to the WebView, not the correct HWND.
Comment 1 Adam Roben (:aroben) 2010-01-21 15:11:34 PST
(In reply to comment #0)
> No events on the plugin are fired to us. Adam Roben said this could be because
> we send the events directly to the WebView, not the correct HWND.

...where "the correct HWND" would be the one under the mouse.
Comment 2 Jessie Berlin 2011-06-13 13:32:26 PDT
Windows appears to be sending the mouseDown and mouseUp events now, but is still missing the getFocusEvent:

http://build.webkit.org/results/Windows%207%20Release%20(Tests)/r88665%20(13701)/plugins/mouse-events-pretty-diff.html
http://build.webkit.org/results/Windows%207%20Release%20(Tests)/r88665%20(13701)/plugins/mouse-events-fixedpos-pretty-diff.html

I am going to update the expected results to reflect that.
Comment 3 Jessie Berlin 2011-06-13 13:43:40 PDT
Updated the failing results in http://trac.webkit.org/changeset/88684
Comment 4 Jessie Berlin 2011-06-13 13:44:10 PDT
<rdar://problem/9600845>
Comment 5 noel gordon 2011-07-12 07:15:15 PDT
Focus events are now forwarded to plugins on the windows port.

Updated expectations for platform/win/plugins/mouse-events.html
  http://trac.webkit.org/changeset/90742

Updated expectations for platform/win/plugins/mouse-events-fixedpos.html 
  http://trac.webkit.org/changeset/90816