Bug 33790

Summary: Web Inspector: Improve ResourcesPanel performance with lots of resources
Product: WebKit Reporter: Alexander Pavlov (apavlov) <apavlov>
Component: Web Inspector (Deprecated)Assignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: bweinstein, commit-queue, eric, gns, joepeck, keishi, pfeldman, pmuellr, rik, timothy, xan.lopez
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
patch none

Description Alexander Pavlov (apavlov) 2010-01-18 02:31:32 PST
There are several bottlenecks in the ResourcesPanel, which dramatically impact performance when working with 1000s of resources.
Comment 1 Alexander Pavlov (apavlov) 2010-01-18 05:31:22 PST
Created attachment 46813 [details]
patch
Comment 2 WebKit Commit Bot 2010-01-18 06:20:57 PST
Comment on attachment 46813 [details]
patch

Clearing flags on attachment: 46813

Committed r53405: <http://trac.webkit.org/changeset/53405>
Comment 3 WebKit Commit Bot 2010-01-18 06:21:05 PST
All reviewed patches have been landed.  Closing bug.
Comment 4 Timothy Hatcher 2010-01-18 08:38:39 PST
Comment on attachment 46813 [details]
patch

Nice patch!

> +    var aVal = a.endTime;
> +    var bVal = b.endTime;

Const would have been good here too.
Comment 5 Eric Seidel (no email) 2010-01-18 11:32:44 PST
Gtk bot seems to have had kittens after this landed:
http://build.webkit.org/results/GTK%20Linux%20Release/r53405%20(7765)/results.html

Not sure it's related to this change though.
Comment 6 Eric Seidel (no email) 2010-01-18 11:35:51 PST
Xan might know what's up with the gtk bot.
Comment 7 Xan Lopez 2010-01-18 11:42:06 PST
(In reply to comment #6)
> Xan might know what's up with the gtk bot.

Actually Gustavo handles the Release bot, I'm the Debug bots guy :)

Looks like random (and possibly unrelated) gstreamer/media woes though, IIRC it has happened before. CCing Gustavo.
Comment 8 Gustavo Noronha (kov) 2010-01-19 11:08:46 PST
(In reply to comment #7)
> (In reply to comment #6)
> > Xan might know what's up with the gtk bot.
> 
> Actually Gustavo handles the Release bot, I'm the Debug bots guy :)
> 
> Looks like random (and possibly unrelated) gstreamer/media woes though, IIRC it
> has happened before. CCing Gustavo.

This is actually caused by pulseaudio misbehaving. I'll try to figure it out.