Bug 33634

Summary: REGRESSION(53133): webkit-patch land dies if it can't find a bug id.
Product: WebKit Reporter: Kenneth Russell <kbr>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, eric, hamaji
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
Patch darin: review+

Description Kenneth Russell 2010-01-13 16:03:30 PST
"webkit-patch land" does not work for a new committer updating committers.py. Here is the Python traceback:

Traceback (most recent call last):
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkit-patch", line 108, in <module>
    WebKitPatch().main()
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkitpy/multicommandtool.py", line 299, in main
    return command.check_arguments_and_execute(options, args, self)
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkitpy/multicommandtool.py", line 113, in check_arguments_and_execute
    return self.execute(options, args, tool) or 0
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkitpy/commands/abstractsequencedcommand.py", line 43, in execute
    self._sequence.run_and_handle_errors(tool, options, self._prepare_state(options, args, tool))
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkitpy/stepsequence.py", line 66, in run_and_handle_errors
    self._run(tool, options, state)
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkitpy/stepsequence.py", line 60, in _run
    step(tool, options).run(state)
  File "/Users/kbr/src/chrome2/src/third_party/WebKit/WebKitTools/Scripts/webkitpy/steps/updatechangelogswithreviewer.py", line 54, in run
    bug_id = state.get("bug_id") or state["patch"].bug_id()
KeyError: 'patch'
Comment 1 Eric Seidel (no email) 2010-01-13 16:14:08 PST
It's failing to find "bug_id", it should never end up down the "patch" path here.

I suspect this happens when your ChangeLog is missing a bug id and is a recent regression from my Attachment refactoring: http://trac.webkit.org/changeset/53133
Comment 2 Adam Barth 2010-01-13 16:46:53 PST
Created attachment 46527 [details]
Patch
Comment 3 Adam Barth 2010-01-13 16:49:12 PST
Committed r53215: <http://trac.webkit.org/changeset/53215>
Comment 4 Shinichiro Hamaji 2010-02-01 19:22:06 PST
*** Bug 33578 has been marked as a duplicate of this bug. ***