Bug 33482

Summary: Add a test for Russian text search
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: Tools / TestsAssignee: Alexey Proskuryakov <ap>
Status: RESOLVED FIXED    
Severity: Normal CC: eric
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
proposed patch sam: review+

Description Alexey Proskuryakov 2010-01-11 11:57:37 PST
There are a couple non-trivial cases that would be nice to test for.
Comment 1 Alexey Proskuryakov 2010-01-11 12:01:30 PST
Created attachment 46296 [details]
proposed patch

There is one failing subtest. The issue is minor, I don't even want to file a bug about it yet.
Comment 2 Alexey Proskuryakov 2010-01-11 12:36:05 PST
Committed revision 53095.
Comment 3 Eric Seidel (no email) 2010-01-11 12:56:41 PST
This new test fails on the Qt bot:
http://build.webkit.org/results/Qt%20Linux%20Release/r53095%20(5842)/fast/text/find-russian-diffs.txt
Comment 4 Alexey Proskuryakov 2010-01-11 13:21:19 PST
Qt just needs expected failure results checked in (and maybe a bug to track fixing platform-specific problems).
Comment 5 Eric Seidel (no email) 2010-01-11 13:25:19 PST
Can you please do so?  The bots were green before your and Darin's checkins.