Bug 33434

Summary: media/video-error-does-not-exist.html failed on Snow Leopard Release Bot
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: cmarrin, commit-queue, eric.carlson, simon.fraser, zimmermann
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on: 32339    
Bug Blocks: 33292    
Attachments:
Description Flags
Patch none

Description Eric Seidel (no email) 2010-01-09 15:22:12 PST
media/video-error-does-not-exist.html failed on Snow Leopard Release Bot

http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r53038%20(4074)/results.html

--- layout-test-results/media/video-error-does-not-exist-expected.txt	2010-01-09 00:03:34.000000000 -0800
+++ layout-test-results/media/video-error-does-not-exist-actual.txt	2010-01-09 00:03:34.000000000 -0800
@@ -1,16 +1,7 @@
+FAIL: Timed out waiting for notifyDone to be called
 Test that the media element is in correct state after load fails.
 
 
 EXPECTED (video.error == 'null') OK
 
-EVENT(error)
-EXPECTED (video.error != 'null') OK
-EXPECTED (video.error.code == '4') OK
-EXPECTED (video.networkState == '4') OK
-EXPECTED (isNaN(video.duration) == 'true') OK
-EXPECTED (video.currentTime == '0') OK
-EXPECTED (video.buffered.length == '0') OK
-EXPECTED (video.seekable.length == '0') OK
-EXPECTED (video.buffered.length == '0') OK
-END OF TEST
 
I get the impression that *all* media tests are flakey on Snow Leopard.  I suspect that QuickTime is hanging or just being slow to load in some cases?  Eric Carlson might know more.

We could skip this one too, but at this rate we'll end up skipping all media tests on Snow Leopard (which is better than having an unreliable tree which flips green/red constantly, just not desirable). :(
Comment 1 Eric Seidel (no email) 2010-01-09 15:24:32 PST
Earlier today as well:
http://build.webkit.org/results/SnowLeopard%20Intel%20Release%20(Tests)/r53034%20(4070)/results.html

I expect that this bug is the same root cause as bug 32339, just on a differnet test.
Comment 3 Eric Seidel (no email) 2010-01-10 21:10:24 PST
Created attachment 46256 [details]
Patch
Comment 4 WebKit Commit Bot 2010-01-11 15:54:46 PST
Comment on attachment 46256 [details]
Patch

Rejecting patch 46256 from commit-queue.

Failed to run "['WebKitTools/Scripts/run-webkit-tests', '--no-launch-safari', '--exit-after-n-failures=1', '--quiet']" exit_code: 1
Running build-dumprendertree
Running tests from /Users/eseidel/Projects/CommitQueue/LayoutTests
Testing 11912 test cases.
fast/profiler/stop-profiling-after-setTimeout.html -> crashed

Exiting early after 1 failures. 7859 tests run.
255.78s total testing time

7858 test cases (99%) succeeded
1 test case (<1%) crashed
3 test cases (<1%) had stderr output

Full output: http://webkit-commit-queue.appspot.com/results/182077
Comment 5 Eric Seidel (no email) 2010-01-11 16:15:29 PST
Comment on attachment 46256 [details]
Patch

Flakey test: bug 32643.
Comment 6 WebKit Commit Bot 2010-01-12 03:06:21 PST
Comment on attachment 46256 [details]
Patch

Clearing flags on attachment: 46256

Committed r53128: <http://trac.webkit.org/changeset/53128>
Comment 7 WebKit Commit Bot 2010-01-12 03:06:28 PST
All reviewed patches have been landed.  Closing bug.