Bug 3327

Summary: Exception When Setting Style to Invalid Value Lacks Line/File Information
Product: WebKit Reporter: Mark Rowe (bdash) <mrowe>
Component: JavaScriptCoreAssignee: Maciej Stachowiak <mjs>
Status: VERIFIED FIXED    
Severity: Minor    
Priority: P2    
Version: 412   
Hardware: Mac   
OS: OS X 10.4   
URL: http://bdash.net.nz/files/safari-js-error.html
Attachments:
Description Flags
Retrieve the line number + source URL from the current node if an exception is found during KJS_CHECKEXCEPTIONVALUE.
none
Updated patch using local variable to reduce duplication of effort. none

Description Mark Rowe (bdash) 2005-06-07 20:14:30 PDT
When an Javascript exception is raised due to setting a CSS property to an invalid value, the exception 
object lacks line number and file information.

To Reproduce:  Load the above URL in Safari, and check the Javascript Console.  An exception titled 'CSS 
exception 0' is listed with a URL of 'undefined' and line number of 0.

Excepted behaviour:  The Javascript console should contain an exception with the correct URL, http://
bdash.net.nz/files/safari-js-error.html, and line number of 4.
Comment 1 Mark Rowe (bdash) 2005-06-07 20:18:03 PDT
Created attachment 2137 [details]
Retrieve the line number + source URL from the current node if an exception is found during KJS_CHECKEXCEPTIONVALUE.
Comment 2 Mark Rowe (bdash) 2005-06-07 23:51:21 PDT
Created attachment 2142 [details]
Updated patch using local variable to reduce duplication of effort.

Patch updated as requested.  I ran run-webkit-tests earlier after creating my
initial patch, and everything looked ok.  I've pulled in the changes to the
Xcode project files since then though and the tests no longer build so I cannot
verify them with this latest patch applied.
Comment 3 Maciej Stachowiak 2005-06-08 00:25:42 PDT
r=me
Comment 4 Maciej Stachowiak 2005-06-08 00:27:26 PDT
Committed the change.
Comment 5 Chris Petersen 2005-06-18 23:00:52 PDT
Reporter, please mark this bug as Verified if this issue has been fixed in the latest TOT Webkit.