Bug 32716

Summary: [Qt] Clean up the qmake build system to distinguish between trunk builds and package builds
Product: WebKit Reporter: Simon Hausmann <hausmann>
Component: New BugsAssignee: Nobody <webkit-unassigned>
Severity: Normal CC: jturcotte, laszlo.gombos, webkit.review.bot
Priority: P3 Keywords: Qt
Version: 528+ (Nightly build)   
Hardware: Other   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 32715    
Description Flags
Patch vestbo: review+

Description Simon Hausmann 2009-12-18 08:41:07 PST
Currently the .pro files use QTDIR_build to distinguish between a build of QtWebKit inside Qt or from the trunk.

What QTDIR_build really means is that QtWebKit is built as a package, where for example generated files are present.
Comment 1 Simon Hausmann 2009-12-18 08:44:25 PST
Created attachment 45152 [details]
Comment 2 WebKit Review Bot 2009-12-18 08:47:15 PST
style-queue ran check-webkit-style on attachment 45152 [details] without any errors.
Comment 3 Simon Hausmann 2009-12-18 09:02:32 PST
Created attachment 45155 [details]
Comment 4 WebKit Review Bot 2009-12-18 09:03:01 PST
style-queue ran check-webkit-style on attachment 45155 [details] without any errors.
Comment 5 Simon Hausmann 2009-12-18 09:06:52 PST
Committed r52313: <http://trac.webkit.org/changeset/52313>
Comment 6 Laszlo Gombos 2009-12-18 09:39:35 PST
Good stuff. src_package might be a better name than standalone_package.