Bug 32702

Summary: SVG filter gets clipped on use of opacity < 1
Product: WebKit Reporter: Dirk Schulze <krit>
Component: SVGAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: eric, zimmermann
Priority: P2    
Version: 525.x (Safari 3.1)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on:    
Bug Blocks: 68469, 26389    
Attachments:
Description Flags
filter with opacity none

Description Dirk Schulze 2009-12-18 01:10:36 PST
Created attachment 45130 [details]
filter with opacity

SVG filter gets clipped on use of opacity < 1. See: http://trac.webkit.org/browser/trunk/WebCore/rendering/SVGRenderSupport.cpp#L93
We could either delete the clipping, or try to get the filter rect. And we need to take the union of filter rect and objectboundingbox.
I have to take a look, if it is possible to get the filter rect some how.
Comment 1 Dirk Schulze 2009-12-18 05:24:26 PST
Sorry, didn't noticed that this is a duplicate of another bug.

*** This bug has been marked as a duplicate of bug 32584 ***