Bug 32696

Summary: HTMLInputElement::valueAsNumber support
Product: WebKit Reporter: Kent Tamura <tkent@chromium.org>
Component: FormsAssignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED FIXED    
Severity: Normal CC: bweinstein@apple.com, darin@apple.com
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
URL: http://www.whatwg.org/specs/web-apps/current-work/multipage/common-input-element-attributes.html#dom-input-valueasnumber
Bug Depends on: 32697    
Bug Blocks: 19264, 29070, 30847, 34200, 34240    
Attachments:
Description Flags
Proposed patch darin: review+

Description From 2009-12-17 22:03:26 PST
It is helpful to implement min/max/step attribute for the date&time types.
------- Comment #1 From 2010-01-26 01:24:12 PST -------
Created an attachment (id=47393) [details]
Proposed patch
------- Comment #2 From 2010-01-26 01:25:40 PST -------
Add Darin to cc, who reviewed all of patches for valueAsDate. valueAsDate is very related to valueAsNumber.
------- Comment #3 From 2010-01-26 09:01:49 PST -------
(From update of attachment 47393 [details])
> +    const double nan = std::numeric_limits<double>::quiet_NaN();

Normally we omit the "std" for things like this, and have "using namespace std" at the top of the file.

r=me
------- Comment #4 From 2010-01-26 20:46:40 PST -------
(In reply to comment #3)
> (From update of attachment 47393 [details] [details])
> > +    const double nan = std::numeric_limits<double>::quiet_NaN();
> 
> Normally we omit the "std" for things like this, and have "using namespace std"
> at the top of the file.

Removed std::, and landed as r53893.
------- Comment #5 From 2010-01-27 16:24:16 PST -------
This test failed on Windows since it was created. Landed expected failing results for Windows in r53959.
------- Comment #6 From 2010-01-27 16:39:24 PST -------
(In reply to comment #5)
> This test failed on Windows since it was created. Landed expected failing
> results for Windows in r53959.

I'll investigate it today.
------- Comment #7 From 2010-01-27 20:45:24 PST -------
(In reply to comment #6)
> (In reply to comment #5)
> > This test failed on Windows since it was created. Landed expected failing
> > results for Windows in r53959.
> 
> I'll investigate it today.

I made a bug entry for the failure: Bug#34240.