Bug 32524

Summary: REGRESSION(52084): fast/dom/prototypes.html failing two CSS tests
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: Tools / TestsAssignee: Geoffrey Garen <ggaren>
Status: RESOLVED FIXED    
Severity: Normal CC: ggaren, hausmann, ossy, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
patch simon.fraser: review+

Description Eric Seidel (no email) 2009-12-14 09:57:31 PST
REGRESSION(52084?): fast/dom/prototypes.html failing two CSS tests

Buildbot seems to think that:
http://trac.webkit.org/changeset/52084
is the cause, but that change seems unrelated.

http://build.webkit.org/results/Leopard%20Intel%20Release%20(Tests)/r52096%20(8321)/fast/dom/prototypes-pretty-diff.html
Comment 1 Eric Seidel (no email) 2009-12-14 09:59:32 PST
The build for r52083 had 2 failures, but they were unrelated to this one:
http://build.webkit.org/builders/Leopard%20Intel%20Release%20(Tests)/builds/8305
Comment 2 Geoffrey Garen 2009-12-14 10:17:49 PST
I think the parentheses in http://trac.webkit.org/changeset/52084 may have been wrong. If so, it's definitely related.
Comment 3 Geoffrey Garen 2009-12-14 10:27:32 PST
Confirmed. http://trac.webkit.org/changeset/52084 was bogus.
Comment 4 Geoffrey Garen 2009-12-14 10:32:53 PST
Created attachment 44807 [details]
patch
Comment 5 Csaba Osztrogon√°c 2009-12-14 10:33:44 PST
Ooops, sorry. "+" has really higher precedence than "&".
Comment 6 WebKit Review Bot 2009-12-14 10:34:30 PST
style-queue ran check-webkit-style on attachment 44807 [details] without any errors.
Comment 7 Geoffrey Garen 2009-12-14 10:41:41 PST
http://trac.webkit.org/changeset/52101
Comment 8 Geoffrey Garen 2009-12-14 10:55:36 PST
This should also fix a GC test failure on Windows.