Bug 32425

Summary: WebCore::executeToggleStyleInList ReadAV@NULL (08a7de8db480c4e2b2ae552176cb3df1)
Product: WebKit Reporter: Berend-Jan Wever <skylined>
Component: HTML EditingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: enrica, eric
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows Vista   
URL: http://skypher.com/SkyLined/Repro/WebKit/Bug%2032425%20-%20WebCore..executeToggleStyleInList%20ReadAV@NULL%20(08a7de8db480c4e2b2ae552176cb3df1)/repro.html
Attachments:
Description Flags
Repro none

Description Berend-Jan Wever 2009-12-11 04:57:27 PST
Created attachment 44675 [details]
Repro

Id:          WebCore::executeToggleStyleInList ReadAV@NULL (08a7de8db480c4e2b2ae552176cb3df1)
Description: Attempt to read from NULL pointer in WebCore::executeToggleStyleInList
Stack:
  WebCore::executeToggleStyleInList
  WebCore::executeStrikethrough
  WebCore::Editor::Command::execute
  WebCore::Document::execCommand
  WebCore::DocumentInternal::execCommandCallback
  v8::internal::Builtin_HandleApiCall
  v8::internal::Invoke
  v8::internal::Execution::Call
  v8::Script::Run
  WebCore::V8Proxy::runScript
  WebCore::V8Proxy::evaluate
  WebCore::ScriptController::evaluate
  WebCore::ScriptController::executeScript
  WebCore::ScriptController::executeScript
  WebCore::ScriptController::executeIfJavaScriptURL
  WebCore::FrameLoader::changeLocation
  WebCore::RedirectScheduler::timerFired
  WebCore::Timer<...>::fired
  WebCore::ThreadTimers::sharedTimerFiredInternal
  MessageLoop::RunTask
  MessageLoop::DoWork
  base::MessagePumpDefault::Run
  MessageLoop::RunInternal
  MessageLoop::Run
  RendererMain
  ChromeMain
Repro:
<BODY></BODY>
<SCRIPT>
  document.execCommand("selectall",false,2);
  document.designMode="on";
  document.execCommand("InsertHorizontalRule",false,"");
  document.execCommand("Delete",false,"");
  document.designMode="";
  document.execCommand("undo",false,"");
  document.designMode ="on";
  document.execCommand("strikethrough",false,false);
</SCRIPT>
Comment 1 Berend-Jan Wever 2009-12-11 04:59:54 PST
Online repro
Comment 2 Enrica Casucci 2009-12-11 10:31:45 PST
I cannot reproduce this with Safari for Mac.
Comment 3 Berend-Jan Wever 2009-12-31 02:32:19 PST
Mike Moretti claims there is a problem with "Undo" after "designmode off".
https://bugs.webkit.org/show_bug.cgi?id=32822
I am assuming this is a variation of that problem.

*** This bug has been marked as a duplicate of bug 32823 ***