Bug 32061

Summary: REGRESSION(51590): style-queue and build-queue think they are empty when they are not
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: abarth, commit-queue, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Attachments:
Description Flags
Patch none

Description Eric Seidel (no email) 2009-12-02 02:22:36 PST
style-queue and build-queue think their empty when they are not

This is due to a regression from r51590.  In fetch_attachment, we depend on attachment['id'] == attachment_id.  Thats not true if one is an int and the other is a string.

Lets fix all ids to be ints, and update the unit tests accordingly.  The unit test I was fixing in r51590 was wrong.

For now I'm papering over the comparison problem because fetch_attachment is very difficult to test due to there being no network abstraction in bugzilla that I can Mock out.
Comment 1 Eric Seidel (no email) 2009-12-02 02:25:48 PST
Created attachment 44138 [details]
Patch
Comment 2 WebKit Review Bot 2009-12-02 02:28:35 PST
style-queue ran check-webkit-style on attachment 44138 [details] without any errors.
Comment 3 Adam Barth 2009-12-02 02:29:36 PST
Comment on attachment 44138 [details]
Patch

Thanks.  Sorry about the bad test.
Comment 4 Mark Rowe (bdash) 2009-12-02 02:39:47 PST
“think *they are* empty”
Comment 5 Eric Seidel (no email) 2009-12-02 02:40:50 PST
Thanks.  :)  I should not still be awake at 6am my body's time. ;p
Comment 6 WebKit Commit Bot 2009-12-02 02:44:35 PST
Comment on attachment 44138 [details]
Patch

Clearing flags on attachment: 44138

Committed r51595: <http://trac.webkit.org/changeset/51595>
Comment 7 WebKit Commit Bot 2009-12-02 02:44:40 PST
All reviewed patches have been landed.  Closing bug.