Bug 31231

Summary: Closing brace in value breaks CSS parser
Product: WebKit Reporter: Alexey Proskuryakov <ap>
Component: CSSAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: adele, bdakin, commit-queue, webkit.review.bot, yuzo
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Attachments:
Description Flags
test 1
none
test 2
none
Skip invalid blocks in CSS property declarations. none

Description Alexey Proskuryakov 2009-11-07 15:17:13 PST
Created attachment 42705 [details]
test 1

From <http://habrahabr.ru/blogs/css/74565>.

After e.g. '.myclass {height:{}}', nothing else gets parsed. See attached test cases.
Comment 1 Alexey Proskuryakov 2009-11-07 15:17:33 PST
Created attachment 42706 [details]
test 2
Comment 2 Yuzo Fujishima 2010-01-07 23:59:09 PST
Created attachment 46117 [details]
Skip invalid blocks in CSS property declarations.
Comment 3 WebKit Review Bot 2010-01-07 23:59:51 PST
style-queue ran check-webkit-style on attachment 46117 [details] without any errors.
Comment 4 Yuzo Fujishima 2010-01-08 00:00:43 PST
The above patch should also fix 26619.

Yuzo
Comment 5 WebKit Commit Bot 2010-01-08 13:31:40 PST
Comment on attachment 46117 [details]
Skip invalid blocks in CSS property declarations.

Clearing flags on attachment: 46117

Committed r53004: <http://trac.webkit.org/changeset/53004>
Comment 6 WebKit Commit Bot 2010-01-08 13:31:45 PST
All reviewed patches have been landed.  Closing bug.
Comment 7 Yuzo Fujishima 2010-01-11 20:11:28 PST
*** Bug 26619 has been marked as a duplicate of this bug. ***
Comment 8 Adele Peterson 2010-01-13 22:05:07 PST
This change introduced a serious bug at redfin.com - https://bugs.webkit.org/show_bug.cgi?id=33650