Bug 31166

Summary: [Qt] Shift-PageUp and Shift-PageDown events not supported on Qt
Product: WebKit Reporter: Chang Shu <cshu>
Component: WebKit QtAssignee: Chang Shu <cshu>
Status: RESOLVED FIXED    
Severity: Normal CC: abecsi, commit-queue
Priority: P3    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
fix patch
none
fix patch with some coding style change none

Description Chang Shu 2009-11-05 06:30:25 PST
Open the following page in QtLauncher:
LayoutTests/editing/selection/shrink-selection-after-shift-pagedown.html

Try to use Shift-PageUp and Shift-PageDown to select texts.

Actual result:
Shift-PageUp and Shift-PageDown behaves like PageUP and PageDown.

Expected result:
The selected text should change accordingly.
Comment 1 Chang Shu 2009-11-05 06:37:54 PST
Created attachment 42567 [details]
fix patch
Comment 2 Chang Shu 2009-11-05 06:51:06 PST
Created attachment 42568 [details]
fix patch with some coding style change
Comment 3 Tor Arne Vestbø 2009-11-05 07:41:19 PST
Comment on attachment 42568 [details]
fix patch with some coding style change

Thanks
Comment 4 WebKit Commit Bot 2009-11-05 07:48:51 PST
Comment on attachment 42568 [details]
fix patch with some coding style change

Clearing flags on attachment: 42568

Committed r50563: <http://trac.webkit.org/changeset/50563>
Comment 5 WebKit Commit Bot 2009-11-05 07:48:56 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Andras Becsi 2009-11-05 08:06:36 PST
(In reply to comment #5)
> All reviewed patches have been landed.  Closing bug.

There still seems to be a problem with Shift+Up:

-SUCCESS: The selection shrunk correctly
+SUCCESS: The selected text is "YES YES YES YES YES YES YES YES YES NO".
Comment 7 Chang Shu 2009-11-05 08:21:05 PST
(In reply to comment #6)
> (In reply to comment #5)
> > All reviewed patches have been landed.  Closing bug.
> 
> There still seems to be a problem with Shift+Up:
> 
> -SUCCESS: The selection shrunk correctly
> +SUCCESS: The selected text is "YES YES YES YES YES YES YES YES YES NO".

This patch does not fix the test case yet. The problem is addressed in bug 31122. please also check some comments I wrote for 31103. Thanks