Bug 30576

Summary: [GTK] Failing DnD tests
Product: WebKit Reporter: Xan Lopez <xan.lopez>
Component: WebKitGTKAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: dbates, gustavo, mrobinson
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: PC   
OS: OS X 10.5   
Bug Depends on: 30623    
Bug Blocks:    

Description Xan Lopez 2009-10-20 09:42:06 PDT
fast/events/drag-and-drop-dataTransfer-types-nocrash.html
fast/events/drag-and-drop-none.html
fast/events/drag-and-drop.html
fast/events/drag-parent-node.html

The only common thing between them seems to be messages about event.dataTransfer{.dropEffect} in the failure messages.
Comment 1 Daniel Bates 2009-11-10 23:05:59 PST
Also failing, test case /fast/events/drag-and-drop-fire-drag-dragover.html

This might be related to this bug.
Comment 2 Gustavo Noronha (kov) 2009-11-12 13:26:57 PST
And http/tests/misc/bubble-drag-events.html
Comment 3 Gustavo Noronha (kov) 2009-11-30 11:49:30 PST
I'm pretty sure this is also the problem for: fast/dom/Window/window-postmessage-clone.html
Comment 4 Csaba Osztrogon√°c 2010-02-04 15:40:04 PST
new one: editing/pasteboard/drop-inputtext-acquires-style.html
Skipped by http://trac.webkit.org/changeset/54379
Comment 5 Martin Robinson 2010-06-17 10:56:23 PDT
Closing this bug as a duplicate of the GTK+ drag-and-drop ultra-metabug.

*** This bug has been marked as a duplicate of bug 30623 ***