Bug 29437

Summary: [Qt] WebKit unable to build in MSVC2008
Product: WebKit Reporter: Tor Arne Vestbø <vestbo@webkit.org>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned@lists.webkit.org>
Status: RESOLVED WORKSFORME    
Severity: Blocker CC: hausmann@webkit.org
Priority: P2 Keywords: Qt
Version: 528+ (Nightly build)   
Hardware: Other   
OS: Mac OS X 10.5   
Bug Depends on:    
Bug Blocks: 29799    

Description From 2009-09-18 07:47:52 PST
This bug report originated from issue QTBUG-3662
<http://bugreports.qt.nokia.com/browse/QTBUG-3662>

--- Description ---

I just ran the configure and nmake commands as directed in the docs 


I expected WebKit to build properly 

Here is the output I got from the command line: 
"""""""""""""" 
        cl -c -FIWebKit_pch.h -YuWebKit_pch.h -Fptmp\obj\release_shared\QtWebKit 
_pch.pch -nologo -Zm200 -Zc:wchar_t- -O2 -MD -GL -GR -EHsc -DQT_SHARED -DQT_THRE 
AD_SUPPORT -DUNICODE -DWIN32 -DQT_LARGEFILE_SUPPORT -DBUILDING_QT__=1 -DUSE_SYST 
EM_MALLOC -DNDEBUG -DQT_MAKEDLL -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS - 
DQT3_SUPPORT -DQT_MOC_COMPAT -D_USE_MATH_DEFINES -DBUILD_WEBKIT -D_HAS_TR1=0 -DE 
NABLE_OFFLINE_WEB_APPLICATIONS=1 -DENABLE_DOM_STORAGE=1 -DENABLE_ICONDATABASE=1 
-DENABLE_DATABASE=1 -DENABLE_DASHBOARD_SUPPORT=0 -DENABLE_XPATH=1 -DENABLE_WML=0 
 -DENABLE_SVG=1 -DENABLE_SVG_FONTS=1 -DENABLE_SVG_FILTERS=1 -DENABLE_SVG_FOREIGN 
_OBJECT=1 -DENABLE_SVG_ANIMATION=1 -DENABLE_SVG_AS_IMAGE=1 -DENABLE_SVG_USE=1 -D 
ENABLE_VIDEO=1 -DENABLE_NETSCAPE_PLUGIN_API=1 -DWTF_USE_JAVASCRIPTCORE_BINDINGS= 
1 -DWTF_CHANGES=1 -DBUILDING_QT__ -DSQLITE_CORE -DSQLITE_OMIT_LOAD_EXTENSION -DS 
QLITE_OMIT_COMPLETE -DQT_DLL -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CO 
RE_LIB -I"..\..\..\..\include\QtCore" -I"..\..\..\..\include\QtNetwork" -I"..\.. 
\..\..\include\QtGui" -I"..\..\..\..\include" -I"storage" -I"..\JavaScriptCore\o 
s-win32" -I"..\WebKit\qt\Api" -I"..\..\..\..\include\QtWebKit" -I"tmp\rcc\debug_ 
shared" -I"tmp" -I"." -I"..\JavaScriptCore" -I"..\JavaScriptCore\ForwardingHeade 
rs" -I"..\JavaScriptCore\interpreter" -I"..\JavaScriptCore\bytecode" -I"..\JavaS 
criptCore\debugger" -I"..\JavaScriptCore\parser" -I"..\JavaScriptCore\runtime" - 
I"c:\Qt\4.5.0-rc1\src\3rdparty\webkit\WebCore\..\JavaScriptCore\bindings" -I"..\ 
JavaScriptCore\wrec" -I"..\JavaScriptCore\jit" -I"..\JavaScriptCore\wtf" -I"tmp" 
 -I"..\JavaScriptCore" -I"..\JavaScriptCore\parser" -I"..\JavaScriptCore\bytecom 
piler" -I"..\JavaScriptCore\debugger" -I"..\JavaScriptCore\runtime" -I"..\JavaSc 
riptCore\wtf" -I"..\JavaScriptCore\wtf\unicode" -I"..\JavaScriptCore\interpreter 
" -I"..\JavaScriptCore\jit" -I"..\JavaScriptCore\profiler" -I"..\JavaScriptCore\ 
wrec" -I"..\JavaScriptCore\API" -I"..\..\webkit" -I"..\JavaScriptCore\Forwarding 
Headers" -I"..\JavaScriptCore\bytecode" -I"..\JavaScriptCore\assembler" -I"..\Ja 
vaScriptCore\os-win32" -I"..\JavaScriptCore\pcre" -I"c:\Qt\4.5.0-rc1\src\3rdpart 
y\webkit\WebKitBuild\Debug\JavaScriptCore\tmp" -I"platform\qt" -I"platform\netwo 
rk\qt" -I"platform\graphics\filters" -I"platform\graphics\transforms" -I"platfor 
m\graphics\qt" -I"svg\graphics\qt" -I"loader" -I"page\qt" -I"..\WebKit\qt\WebCor 
eSupport" -I"..\WebKit\qt\Api" -I"bridge\qt" -I"." -I"ForwardingHeaders" -I"..\. 
.\webkit" -I"platform" -I"platform\animation" -I"platform\network" -I"platform\g 
raphics" -I"svg\animation" -I"svg\graphics" -I"svg\graphics\filters" -I"platform 
\sql" -I"platform\text" -I"loader" -I"loader\appcache" -I"loader\archive" -I"loa 
der\icon" -I"css" -I"dom" -I"page" -I"page\animation" -I"bridge" -I"editing" -I" 
rendering" -I"rendering\style" -I"history" -I"inspector" -I"xml" -I"html" -I"wml 
" -I"bindings\js" -I"svg" -I"platform\image-decoders" -I"plugins" -I"bridge" -I" 
bridge\c" -I"bridge\qt" -I"generated" -I"plugins\win" -I"..\..\sqlite" -I"..\..\ 
..\..\include\phonon" -I"..\..\..\..\include\ActiveQt" -I"tmp\moc\release_shared 
" -I"." -I"..\..\..\..\mkspecs\win32-msvc2008" -Fotmp\obj\release_shared\ @C:\Us 
ers\NEALGO~1\AppData\Local\Temp\1\nm292C.tmp 
qrc_WebKit.cpp 
qrc_WebCore.cpp 
        link /LIBPATH:"c:\Qt\4.5.0-rc1\lib" /LIBPATH:"c:\Qt\4.5.0-rc1\lib" /NOLO 
GO /INCREMENTAL:NO /LTCG /DLL /MANIFEST /MANIFESTFILE:"tmp\obj\release_shared\Qt 
WebKit.intermediate.manifest" /VERSION:4.50 /OUT:..\..\..\..\lib\QtWebKit4.dll @ 
C:\Users\NEALGO~1\AppData\Local\Temp\1\nm37D3.tmp 
   Creating library ..\..\..\..\lib\QtWebKit4.lib and object ..\..\..\..\lib\QtW 
ebKit4.exp 
CSSStyleSelector.obj : error LNK2001: unresolved external symbol "private: void 
__thiscall WebCore::CSSStyleSelector::applySVGProperty(int,class WebCore::CSSVal 
ue *)" (?applySVGProperty@CSSStyleSelector@WebCore@@AAEXHPAVCSSValue@2@@Z) 
..\..\..\..\lib\QtWebKit4.dll : fatal error LNK1120: 1 unresolved externals 
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\BIN 
\link.EXE"' : return code '0x460' 
Stop. 
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\BIN 
\nmake.exe"' : return code '0x2' 
Stop. 
NMAKE : fatal error U1077: 'cd' : return code '0x2' 
Stop. 
""""""""""
------- Comment #1 From 2009-09-29 03:18:42 PST -------
We cannot reproduce this problem anymore. Qt 4.5.0's WebKit builds with MSVC 2008, and so does Qt 4.6.