Bug 29089

Summary: Inspector should remember preferences for docked/undocked etc
Product: WebKit Reporter: Wells Oliver <wells>
Component: Web Inspector (Deprecated)Assignee: Joseph Pecoraro <joepeck>
Severity: Normal CC: joepeck, timothy
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Description Flags
[PATCH] Remember Resources Large / Small Rows Preference timothy: review+

Description Wells Oliver 2009-09-09 09:56:57 PDT
Inspector should remember a user's settings for preferences such as whether the window is docked, whether small icons are shown, whether the console is open, and so on.
Comment 1 Timothy Hatcher 2009-09-11 17:57:06 PDT
We do remember if it is docked already. The others will be good to remember.
Comment 2 Joseph Pecoraro 2009-10-03 08:31:24 PDT
Created attachment 40575 [details]
[PATCH] Remember Resources Large / Small Rows Preference

I'm open to changing the name "resourcesLargeRows". The naming convention I was going for was "<panel><SettingName>".  But there are so few preferences right now that this might not be needed.
Comment 3 Joseph Pecoraro 2009-10-03 08:35:22 PDT
(In reply to comment #0)
> whether small icons are shown

Current patch attempts this.  Is there anywhere else other then Resources rows? Is there one in the Profiler or something? I seem to remember but I couldn't find anything else.

> whether the console is open

I'm against this. I prefer using ⌥⌘C to open with Console and ⌥⌘I to open without the Console and some extra real estate.  In fact, I'm hoping there can be a Console Only Inspector sometime!
Comment 4 Timothy Hatcher 2009-10-03 16:06:44 PDT
Comment on attachment 40575 [details]
[PATCH] Remember Resources Large / Small Rows Preference

> +        if (resourcesLargeRows !== undefined)

Should be:

typeof resourcesLargeRows !== "undefined"
Comment 5 Joseph Pecoraro 2009-10-03 17:24:27 PDT
(In reply to comment #4)
> (From update of attachment 40575 [details])
> > +        if (resourcesLargeRows !== undefined)
> Should be:
> typeof resourcesLargeRows !== "undefined"

I thought about this (cause we had mentioned it before).  I took a look to check if there were others and felt fine when I saw there were a bunch.  Should I bother changing any of the others?

1058:        return (obj.nodeType === undefined ? type : "node");

698:    if (complete === undefined)

406:        if (this._requestHeaders === undefined)
424:        if (this._sortedRequestHeaders !== undefined)
437:        if (this._responseHeaders === undefined)
455:        if (this._sortedResponseHeaders !== undefined)
576:            && this.contentLength !== undefined

74:    if (child.hasChildren && child.treeOutline._treeElementsExpandedState[child.identifier] !== undefined)
122:    if (child.hasChildren && child.treeOutline._treeElementsExpandedState[child.identifier] !== undefined)
Comment 6 Timothy Hatcher 2009-10-03 17:25:47 PDT
Either works. I just prefer the typeof version now.
Comment 7 Joseph Pecoraro 2009-10-03 20:16:49 PDT
Landed in r49072 => http://trac.webkit.org/changeset/49072
r49072 = 45c28c0b6c817190798c81538d182c8a8312cc35 (trunk)
Comment 8 Joseph Pecoraro 2009-10-03 20:21:17 PDT
Wells Oliver - we're going to mark this as resolved.  If you still feel another preference should be added for the Console let us know.  We are comfortable with the current behavior and the keyboard shortcut solution.