Bug 27584

Summary: [CSS3 Backgrounds and Borders] Handle the / and 4 values in border-radius
Product: WebKit Reporter: Simon Fraser (smfr) <simon.fraser>
Component: CSSAssignee: mitz
Status: RESOLVED FIXED    
Severity: Normal CC: bugzilla33, mitz
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: All   
OS: All   
Bug Depends on:    
Bug Blocks: 27569    
Attachments:
Description Flags
Support the new border-radius syntax and maintain legacy -webkit-border-radius syntax simon.fraser: review+

Description Simon Fraser (smfr) 2009-07-22 16:11:00 PDT
CSS 3 border radius has the ability to specify 4 values at one time, and separate values with a /. We need to handle these.

We already handle the radius-reducing algorithm in the spec.
Comment 1 mitz 2009-07-28 17:02:36 PDT
Created attachment 33680 [details]
Support the new border-radius syntax and maintain legacy -webkit-border-radius syntax
Comment 2 Simon Fraser (smfr) 2009-07-28 17:13:43 PDT
Comment on attachment 33680 [details]
Support the new border-radius syntax and maintain legacy -webkit-border-radius syntax

> Index: WebCore/css/CSSParser.cpp
> ===================================================================


> +    case CSSPropertyBorderRadius:
> +    case CSSPropertyWebkitBorderRadius:
> +        return parseBorderRadius(propId, important);
> +        break;

No need for the break after return.

r=me
Comment 3 mitz 2009-07-28 17:17:45 PDT
Fixed in <http://trac.webkit.org/changeset/46508>.
Comment 4 Adam Roben (:aroben) 2009-07-28 17:18:26 PDT
*** Bug 23675 has been marked as a duplicate of this bug. ***