Bug 242779

Summary: AX: display:contents elements are inserted in the wrong position when they have inline renderer siblings
Product: WebKit Reporter: Tyler Wilcock <tyler_w>
Component: AccessibilityAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: andresg_22, aroselli, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Tyler Wilcock 2022-07-14 18:01:08 PDT
Inline elements are rolled up into a single anonymous block, which breaks our heuristic for inserting display:contents elements to the correct position in AccessibilityRenderObject::addNodeOnlyChildren().

Repro case: https://codepen.io/aardrian/pen/WNvoOpM
Comment 1 Radar WebKit Bug Importer 2022-07-14 18:01:20 PDT
<rdar://problem/97046233>
Comment 2 Tyler Wilcock 2022-08-05 15:39:50 PDT
Fixed by https://bugs.webkit.org/show_bug.cgi?id=243373.

*** This bug has been marked as a duplicate of bug 243373 ***