Bug 24250

Summary: forward-delete in the last cell of a table moves the caret after the table
Product: WebKit Reporter: Eric Seidel (no email) <eric>
Component: HTML EditingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: ayg, darin, dglazkov, enrica, mifenton, rniwa, sukolsak, webkit.review.bot
Priority: P2    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   
Attachments:
Description Flags
test case
none
Patch
none
Patch for landing
none
Archive of layout-test-results from gce-cr-linux-06
none
Patch for landing none

Description Eric Seidel (no email) 2009-02-27 14:01:40 PST
forward-delete in the last cell of a table moves the caret after the table

The caret shouldn't move for foward-delete (as far as I can tell).  So we shouldn't be moving it out of the table here.

See test case.
Comment 1 Eric Seidel (no email) 2009-02-27 14:03:10 PST
Created attachment 28104 [details]
test case
Comment 2 Eric Seidel (no email) 2009-02-27 15:01:34 PST
Still reproduces in Safari 4 (I filed this bug from Safari 3, eek!)
Comment 3 Sukolsak Sakshuwong 2012-07-29 16:14:22 PDT
Created attachment 155186 [details]
Patch
Comment 4 Ryosuke Niwa 2012-07-29 17:25:14 PDT
Comment on attachment 155186 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=155186&action=review

Nice!

> LayoutTests/editing/deleting/forward-delete-empty-table-cell.html:1
> +<html> 

Missing DOCTYPE.
Comment 5 Sukolsak Sakshuwong 2012-07-29 17:39:40 PDT
Created attachment 155190 [details]
Patch for landing
Comment 6 WebKit Review Bot 2012-07-29 18:13:53 PDT
Comment on attachment 155190 [details]
Patch for landing

Attachment 155190 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/13393186

New failing tests:
platform/chromium/compositing/accelerated-drawing/svg-filters.html
platform/chromium/compositing/accelerated-drawing/alpha.html
Comment 7 WebKit Review Bot 2012-07-29 18:13:57 PDT
Created attachment 155192 [details]
Archive of layout-test-results from gce-cr-linux-06

The attached test failures were seen while running run-webkit-tests on the chromium-ews.
Bot: gce-cr-linux-06  Port: <class 'webkitpy.common.config.ports.ChromiumXVFBPort'>  Platform: Linux-2.6.39-gcg-201203291735-x86_64-with-Ubuntu-10.04-lucid
Comment 8 Sukolsak Sakshuwong 2012-07-29 21:26:12 PDT
Created attachment 155205 [details]
Patch for landing
Comment 9 WebKit Review Bot 2012-07-29 22:23:14 PDT
Comment on attachment 155205 [details]
Patch for landing

Clearing flags on attachment: 155205

Committed r123995: <http://trac.webkit.org/changeset/123995>
Comment 10 WebKit Review Bot 2012-07-29 22:23:19 PDT
All reviewed patches have been landed.  Closing bug.