Bug 240049

Summary: REGRESSION(r293703):[ BigSur+ iOS ] TestWTF.WTF_URLExtras.URLExtras_ParsingError (API-Test) is a constant failure
Product: WebKit Reporter: Robert Jenner <jenner>
Component: Web Template FrameworkAssignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
[fast-cq] follow-up fix none

Description Robert Jenner 2022-05-03 17:54:44 PDT
TestWTF.WTF_URLExtras.URLExtras_ParsingError

is a constant failure on BigSur and greater, as well as iOS.

HISTORY:
https://results.webkit.org/?suite=api-tests&test=TestWTF.WTF_URLExtras.URLExtras_ParsingError

    TestWTF.WTF_URLExtras.URLExtras_ParsingError
        
        /Volumes/Data/worker/Apple-iOS-15-Simulator-Debug-Build/build/Tools/TestWebKitAPI/Tests/WTF/cocoa/URLExtras.mm:240
        Expected equality of these values:
          [[url3 absoluteString] UTF8String]
            Which is: "%C3%82%C2%B6%00"
          "%C3%82%C2%B6"
Comment 1 Radar WebKit Bug Importer 2022-05-03 17:55:02 PDT
<rdar://problem/92704160>
Comment 2 Robert Jenner 2022-05-03 18:20:30 PDT
I was able to reproduce the failure at iOS15 and Monterey Debug ToT using the following test:

run-api-tests TestWTF.WTF_URLExtras.URLExtras_ParsingError


We have had some build failures with the Monterey and iOS queues. I am attempting to resolve them, and get the revisions build so I can confirm the regression point. But it looks like it has a pretty clean regression point at r293703
Comment 3 Chris Dumez 2022-05-03 19:06:47 PDT
Pull request: https://github.com/WebKit/WebKit/pull/488
Comment 4 EWS 2022-05-03 23:20:19 PDT
Committed r293761 (250240@main): <https://commits.webkit.org/250240@main>

Reviewed commits have been landed. Closing PR #488 and removing active labels.
Comment 5 Robert Jenner 2022-05-04 14:41:21 PDT
https://commits.webkit.org/250240@main did not resolve the issue with this test. 

In was able to reproduce the same failure at Monterey Debug ToT
Comment 6 Chris Dumez 2022-05-04 15:34:12 PDT
Created attachment 458829 [details]
[fast-cq] follow-up fix
Comment 7 EWS 2022-05-04 16:28:56 PDT
Committed r293802 (250276@main): <https://commits.webkit.org/250276@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 458829 [details].