Bug 239890

Summary: REGRESSION(r290548) [GTK][WPE] test LayoutTests/fast/events/node-event-anchor-lock.html fails
Product: WebKit Reporter: Arcady Goldmints-Orlov <crzwdjk>
Component: Tools / TestsAssignee: Arcady Goldmints-Orlov <crzwdjk>
Status: RESOLVED FIXED    
Severity: Normal CC: mrobinson, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: PC   
OS: Linux   
Attachments:
Description Flags
Patch none

Description Arcady Goldmints-Orlov 2022-04-28 23:35:17 PDT
This test has started failing with the message "FAIL: scrollTop is 600px, but should be more than 600px", because it expects the scrolling that it triggers to be instantaneous and it is not anymore. The easiest thing here is to disable scroll animation as was done for several other tests in r290548.
Comment 1 Arcady Goldmints-Orlov 2022-04-28 23:37:04 PDT
Created attachment 458574 [details]
Patch
Comment 2 EWS 2022-04-29 10:41:20 PDT
Committed r293620 (250126@main): <https://commits.webkit.org/250126@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 458574 [details].
Comment 3 Radar WebKit Bug Importer 2022-04-29 10:42:14 PDT
<rdar://problem/92532244>