Bug 236469

Summary: [WebAuthn] Access group not set in add query for importLocalAuthenticatorCredential
Product: WebKit Reporter: pascoe <pascoe>
Component: WebKit Misc.Assignee: pascoe <pascoe>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch for landing none

Description pascoe@apple.com 2022-02-10 15:59:15 PST
^
Comment 1 Radar WebKit Bug Importer 2022-02-10 15:59:25 PST
<rdar://problem/88783447>
Comment 2 pascoe@apple.com 2022-02-11 08:49:04 PST
Created attachment 451702 [details]
Patch
Comment 3 Brent Fulgham 2022-02-11 10:55:16 PST
Comment on attachment 451702 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=451702&action=review

r=me

> Source/WebKit/ChangeLog:9
> +        In the patch adding support for setting accessGroup, previously did not properly set

Suggestion: In Bug 236311 we added support setting accessGroup, but did not properly set it on the addQuery. This patch fixes that.

> Tools/ChangeLog:14
> +        * TestWebKitAPI/Tests/WebKitCocoa/_WKWebAuthenticationPanel.mm:

Really nice that you managed to create a test to protect this behavior!
Comment 4 pascoe@apple.com 2022-02-14 08:33:30 PST
Created attachment 451905 [details]
Patch for landing
Comment 5 EWS 2022-02-14 13:12:03 PST
Committed r289760 (247232@main): <https://commits.webkit.org/247232@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 451905 [details].