Bug 23537

Summary: REGRESSION (r39969): Garbage text instead of blank content rendered when plug-ins are disabled
Product: WebKit Reporter: Darin Adler <darin>
Component: Plug-insAssignee: Darin Adler <darin>
Status: RESOLVED DUPLICATE    
Severity: Major Keywords: InRadar
Priority: P1    
Version: 528+ (Nightly build)   
Hardware: Mac   
OS: OS X 10.5   

Description Darin Adler 2009-01-25 15:00:14 PST
Code to handle the case where we have an ActiveX plug-in that was added back in http://trac.webkit.org/changeset/39115 combined with code to handle the case of disabled plug-ins in http://trac.webkit.org/changeset/39969 to create a bad effect. Due to the combined effect of these changes we'd ignore the class ID and MIME type entirely, and render plug-in content as HTML.

* STEPS TO REPRODUCE
1) Disable plug-ins
2) Go to http://www.ilounge.com/ or http://www.talkingpointsmemo.com/
3) Reload page if necessary

* RESULTS
Banner ads or sometimes embedded Flash content on those websites contain garbage text rather than being rendered blank.
Comment 1 Mark Rowe (bdash) 2009-01-26 12:31:06 PST

*** This bug has been marked as a duplicate of 23538 ***