Bug 235265

Summary: [Flatpak SDK] local build is broken
Product: WebKit Reporter: ChangSeok Oh <changseok>
Component: WebKitGTKAssignee: ChangSeok Oh <changseok>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, pnormand
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description ChangSeok Oh 2022-01-15 04:24:56 PST
"./Tools/Scripts/webkit-flatpak-sdk --build all" causes a following error. https://releases.freedesktop-sdk.io returned the HTTP 404.

Failure Summary
  bootstrap/build/base-sdk/image-x86_64.bst:
    [00:00:00][0d5e6169][fetch:freedesktop-sdk.bst:bootstrap/build/base-sdk/image-x86_64.bst] FAILURE Fetching remote ref: 562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b from origin: https://releases.freedesktop-sdk.io/releases/
    [00:00:00][0d5e6169][fetch:freedesktop-sdk.bst:bootstrap/build/base-sdk/image-x86_64.bst] FAILURE ostree source at freedesktop-sdk.bst:bootstrap/build/base-sdk/image-x86_64.bst [line 5 column 2]: Failed to fetch ref '562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b' from origin: https://releases.freedesktop-sdk.io/releases/

    Failed to fetch ref '562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b' from 'https___releases_freedesktop_sdk_io_releases_': Server returned HTTP 404

        Printing the last 20 lines from log file:
        /home/changseok/.cache/buildstream/logs/freedesktop-sdk/bootstrap-build-base-sdk-image-x86_64/0d5e6169-fetch.75787.log
        ======================================================================
              -fcf-protection -fno-omit-frame-pointer '
            HOME: /tmp
            LC_ALL: en_US.UTF-8
            LDFLAGS: '-Wl,-z,relro,-z,now -Wl,--as-needed '
            LOGNAME: tomjon
            PATH: /usr/bin:/bin:/usr/sbin:/sbin
            PYTHON: /usr/bin/python3
            PYTHONHASHSEED: '0'
            SHELL: /bin/sh
            SOURCE_DATE_EPOCH: '1320937200'
            TERM: dumb
            TZ: UTC
            USER: tomjon
            USERNAME: tomjon
        [--:--:--] STATUS  bootstrap/build/base-sdk/image-x86_64.bst-0: Creating local mirror for https://releases.freedesktop-sdk.io/releases/
        [--:--:--] START   bootstrap/build/base-sdk/image-x86_64.bst-0: Fetching remote ref: 562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b from origin: https://releases.freedesktop-sdk.io/releases/
        [00:00:00] FAILURE bootstrap/build/base-sdk/image-x86_64.bst-0: Fetching remote ref: 562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b from origin: https://releases.freedesktop-sdk.io/releases/
        [00:00:00] FAILURE bootstrap/build/base-sdk/image-x86_64.bst: ostree source at freedesktop-sdk.bst:bootstrap/build/base-sdk/image-x86_64.bst [line 5 column 2]: Failed to fetch ref '562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b' from origin: https://releases.freedesktop-sdk.io/releases/

        Failed to fetch ref '562381b919ca39bf76ee62adec9ece5de186213f770894fc710e87bfa9e61b6b' from 'https___releases_freedesktop_sdk_io_releases_': Server returned HTTP 404
        ======================================================================

Pipeline Summary
  Total:       631
  Session:     631
  Pull Queue:  processed 3,   skipped 628, failed 0 
  Fetch Queue: processed 502, skipped 128, failed 1 
  Build Queue: processed 0,   skipped 3,   failed 0 


/home/changseok/Projects/WebKit/Tools/Scripts/bst-wrapper  --no-interactive -o arch x86_64 -o bootstrap_build_arch x86_64 checkout --hardlinks --force flatpak-runtimes.bst cache/flatpak-runtimes-repo
[--:--:--][][] START   Loading elements
[00:00:05][][] SUCCESS Loading elements
[--:--:--][][] START   Resolving elements
[00:00:01][][] SUCCESS Resolving elements
[--:--:--][][] START   Resolving cached state
[00:00:06][][] SUCCESS Resolving cached state
[--:--:--][e5e576cc][ main:flatpak-runtimes.bst          ] START   Staging dependencies
[00:00:00][e5e576cc][ main:flatpak-runtimes.bst          ] FAILURE Staging dependencies

Error while staging dependencies into a sandbox: 'No artifacts to stage'

    No artifacts have been cached yet for that element
    Try building the element first with `bst build`

ostree pull-local --repo=repo cache/flatpak-runtimes-repo
error: opening repo: opendir(objects): No such file or directory
make: *** [Makefile:88: EXPORT-cache/flatpak-runtimes-repo] Error 1
Comment 1 Philippe Normand 2022-01-15 08:12:44 PST
$ bst-wrapper track freedesktop-sdk.bst

and try again
Comment 2 Philippe Normand 2022-01-15 09:37:40 PST
The FDO SDK CI/infra recently suffered an incident, they lost (parts of?) their ostree repo. I think the issue is resolved now, but our ref to the FDO junction is now invalid, that why we need to update it.
Comment 3 ChangSeok Oh 2022-01-15 12:42:22 PST
(In reply to Philippe Normand from comment #1)
> $ bst-wrapper track freedesktop-sdk.bst
> 
> and try again

It works like a charm! I will post a patch updating the ref.
Comment 4 ChangSeok Oh 2022-01-15 16:03:04 PST
Created attachment 449277 [details]
Patch
Comment 5 EWS 2022-01-16 01:09:49 PST
Committed r288072 (246092@main): <https://commits.webkit.org/246092@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 449277 [details].