Bug 235015

Summary: Bug in matching domains for hasBrokenEncryptedMediaAPISupportQuirk
Product: WebKit Reporter: Christian Klein <christian.n.klein>
Component: WebCore Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: eric.carlson, jer.noble
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=222130
Attachments:
Description Flags
Adding dot to check for hulu.com subdomain none

Description Christian Klein 2022-01-09 06:26:37 PST
A missing dot in https://github.com/WebKit/WebKit/blob/6850f836d2f6e440cdeeb472778c233785774bf3/Source/WebCore/page/Quirks.cpp#L189 makes all domains ending in "hulu.com". All other domains are matched with the dot, like `.youtube.com`
Comment 1 Christian Klein 2022-01-09 06:51:14 PST
Created attachment 448700 [details]
Adding dot to check for hulu.com subdomain
Comment 2 Alexey Proskuryakov 2022-01-10 09:26:26 PST
Previously reported in bug 222130. I hesitate to dupe in either direction, as this bug has a patch, and the old one talks about an additional issue with vimeo.com.
Comment 3 Eric Carlson 2022-01-10 10:01:34 PST
Thanks for the report and patch Christian.

Lets dup this to bug 222130 because in addition to being older it also, as Alexey notes, reports a similar bug in another quirk.

*** This bug has been marked as a duplicate of bug 222130 ***