Bug 234270

Summary: GTK WK2 failures aren't showing in Bugzilla EWS bubbles.
Product: WebKit Reporter: Jean-Yves Avenard [:jya] <jean-yves.avenard>
Component: Tools / TestsAssignee: Carlos Alberto Lopez Perez <clopez>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: aakash_jain, aperez, ap, clopez, dpino, Hironori.Fujii, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=209104
https://bugs.webkit.org/show_bug.cgi?id=231999
https://bugs.webkit.org/show_bug.cgi?id=234378

Description Jean-Yves Avenard [:jya] 2021-12-13 14:19:30 PST
In bug 233442 I introduced a regression when I applied some of the review comments. This would have lead to a failure.
The bug was an assert if debug build, or a null deref otherwise.

I relatively quickly received an email informing me of the failures.
----

EWS has detected layout test failures on GTK-WK2-Tests-EWS while testing Patch 446967 for Bug 233442.

Full details are available at: https://ews-build.webkit.org/#/builders/35/builds/2902

Patch author: jean-yves.avenard@apple.com

Layout test failures:

- imported/w3c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.center.worker.html (test history)
- imported/w3c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.end.ltr.worker.html (test history)
- imported/w3 c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.end.rtl.worker.html (test history)
- imported/w3c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.left.worker.html (test history)
- imported/w3c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.right.worker.html (test history)
- imported/w3c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.start.ltr.worker.html (test history)
- imported/w3c/web-platform-tests/html/canvas/offscreen/text/2d.text.draw.align.start.rtl.worker.html (test history)
-----

however, bugzilla was showing all green, no GTK WK2 failures could be seen there.
Comment 1 Alexey Proskuryakov 2021-12-13 14:27:59 PST
Looks like this EWS is running, but doesn't have a bubble? Per discussion in bug 209104, it seems like it shouldn't be marking patches cq-.
Comment 2 Radar WebKit Bug Importer 2021-12-13 14:33:03 PST
<rdar://problem/86434401>
Comment 3 Aakash Jain 2021-12-13 14:39:46 PST
(In reply to Alexey Proskuryakov from comment #1)
> Looks like this EWS is running, but doesn't have a bubble? Per discussion in
> bug 209104, it seems like it shouldn't be marking patches cq-.
Bug 209104 was old attempt to add gtk-wk2 queue, and the queue was disabled at that time. 

It was recently re-implemented by Carlos in Bug 231999. The status bubble still needs to be enabled. I agree that if the bubble is not enabled, then it shouldn't cq- the patches.
Comment 4 Carlos Alberto Lopez Perez 2021-12-15 19:05:07 PST
(In reply to Aakash Jain from comment #3)
> (In reply to Alexey Proskuryakov from comment #1)
> > Looks like this EWS is running, but doesn't have a bubble? Per discussion in
> > bug 209104, it seems like it shouldn't be marking patches cq-.
> Bug 209104 was old attempt to add gtk-wk2 queue, and the queue was disabled
> at that time. 
> 
> It was recently re-implemented by Carlos in Bug 231999. The status bubble
> still needs to be enabled. I agree that if the bubble is not enabled, then
> it shouldn't cq- the patches.

Sorry for this. Didn't knew it was cq- patches.

I look forward to enable the bubble ASAP since the queue has been working well.

I'm also adding a few optimizations and more workers to make it faster on bug 234378

I will try to upload a patch here to enable the status bubble.
Comment 5 Carlos Alberto Lopez Perez 2021-12-15 19:53:55 PST
I have uploaded a patch for adding the bubble to the original bug 209104
I'm marking this as duplicate of that one since the other was older.

*** This bug has been marked as a duplicate of bug 209104 ***