Bug 234187

Summary: File sharing on Safari does not resolve in iOS 15.1.1 and 15.0
Product: WebKit Reporter: Tri <tri>
Component: WebKit Misc.Assignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Major CC: ap, bdakin, thorton
Priority: P2    
Version: Safari 15   
Hardware: iPhone / iPad   
OS: iOS 15   

Description Tri 2021-12-10 17:10:26 PST
User is unable to share a file in Safari after saving the file from the share sheet.

1. Open https://w3c.github.io/web-share/demos/share-files.html on Safari on an iOS 15+ device
2. Uncheck URL
3. Set title and text to null
4. Press "Choose Files" to attach any file
5. Click share
6. Select save Image
7. Share button grays out and never changes back to available. No error is logged.

Expected Behavior: User should be able to save an image, trigger the share sheet again and take subsequent sharing actions.
Comment 1 Alexey Proskuryakov 2021-12-13 10:17:34 PST
Thank you for the report! the title seems to imply that this may be a new issue. Could you please confirm whether this worked fine in iOS 14.x?
Comment 2 Tri 2021-12-13 12:07:26 PST
On iOS 14.x file sharing is not supported using `navigator.share` call so we couldn't replicate this bug.
Comment 3 Tim Horton 2021-12-13 12:37:22 PST

*** This bug has been marked as a duplicate of bug 231995 ***