Bug 233665

Summary: [ Monterey ] http/tests/workers/service/serviceworker-websocket.https.html (layout-test) is constant text failure
Product: WebKit Reporter: Robert Jenner <Jenner>
Component: Service WorkersAssignee: youenn fablet <youennf>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: achristensen, cdumez, webkit-bot-watchers-bugzilla, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Robert Jenner 2021-11-30 14:11:43 PST
http/tests/workers/service/serviceworker-websocket.https.html

is a constant text failure on Monterey. 


HISTORY:
https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fworkers%2Fservice%2Fserviceworker-websocket.https.html

DIFF URL:
https://build.webkit.org/results/Apple-Monterey-Release-WK2-Tests/r286311%20(292)/http/tests/workers/service/serviceworker-websocket.https-pretty-diff.html

DIFF TEXT:
 PASS Setup worker
-PASS Open a WebSocket in service worker
+FAIL Open a WebSocket in service worker promise_test: Unhandled rejection with value: "FAIL: websocket had an error: [object Event]"
Comment 1 Radar WebKit Bug Importer 2021-11-30 14:12:05 PST
<rdar://problem/85888177>
Comment 2 Robert Jenner 2021-12-02 17:58:13 PST
This appears to have been a failure since we started testing Monterey on OpenSource.
Comment 3 Robert Jenner 2021-12-02 18:15:14 PST
Updated expectation as Failure for Monterey here:

https://trac.webkit.org/changeset/286472/webkit
Comment 4 youenn fablet 2021-12-09 03:47:12 PST
Created attachment 446516 [details]
Patch
Comment 5 youenn fablet 2021-12-09 05:08:57 PST
stress test failures should be fixed with https://bugs.webkit.org/show_bug.cgi?id=234075.
Comment 6 youenn fablet 2021-12-09 05:11:05 PST
Test is passing in Mac-wk2 EWS bot, instead of consistently failing.
Putting it in r?
Comment 7 EWS 2021-12-10 09:08:41 PST
Committed r286854 (245087@main): <https://commits.webkit.org/245087@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 446516 [details].
Comment 8 Robert Jenner 2021-12-21 16:24:18 PST
(In reply to EWS from comment #7)
> Committed r286854 (245087@main): <https://commits.webkit.org/245087@main>
> 
> All reviewed patches have been landed. Closing bug and clearing flags on
> attachment 446516 [details].

I have confirmed that this test is still failing even after r286854 was committed. I was also able to reproduce the failure locally at Monterey Production ToT.
Comment 9 youenn fablet 2022-01-05 08:16:35 PST

*** This bug has been marked as a duplicate of bug 234809 ***