Bug 233510

Summary: [GPU Process] [Filters 11/23] Move FilterEffect relative absolutePaintRect calculation to FilterImage
Product: WebKit Reporter: Said Abou-Hallawa <sabouhallawa>
Component: Layout and RenderingAssignee: Said Abou-Hallawa <sabouhallawa>
Status: RESOLVED FIXED    
Severity: Normal CC: bfulgham, changseok, dino, esprehn+autocc, ews-watchlist, fmalita, glenn, gyuyoung.kim, heycam, kondapallykalyan, pdr, schenney, sergio, simon.fraser, webkit-bug-importer, zalan
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 231253    
Attachments:
Description Flags
Patch
heycam: review+, ews-feeder: commit-queue-
Patch none

Said Abou-Hallawa
Reported 2021-11-25 21:21:09 PST
This is a step towards simplifying the FilterEffect geometry and removing the FilterImage from FilterEffect.
Attachments
Patch (28.17 KB, patch)
2021-11-25 21:27 PST, Said Abou-Hallawa
heycam: review+
ews-feeder: commit-queue-
Patch (29.78 KB, patch)
2021-11-25 22:53 PST, Said Abou-Hallawa
no flags
Said Abou-Hallawa
Comment 1 2021-11-25 21:27:28 PST
Cameron McCormack (:heycam)
Comment 2 2021-11-25 21:48:51 PST
Comment on attachment 445169 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=445169&action=review > Source/WebCore/ChangeLog:11 > + getting the moved the absolutePaintRect of a FilterEffect. No need for "getting the moved absolutePaintRect"? > Source/WebCore/ChangeLog:12 > + clamping scaling since all FilterImages have to be within MaxClampedArea. "clamping or scaling" > Source/WebCore/platform/graphics/filters/FilterImage.cpp:60 > +IntRect FilterImage::relativeAbsoluteImageRect(const FilterImage& origin) const "relativeAbsoluteImageRect" is a confusing name for me, since "relative" and "absolute" are opposites. I'm struggling to come up with a good name -- something like "absoluteImageRectRelativeToFilterImage"? Not sure. Maybe there could be a better name if the "this" and argument were the other way around?
Said Abou-Hallawa
Comment 3 2021-11-25 22:53:59 PST
Said Abou-Hallawa
Comment 4 2021-11-25 23:18:04 PST
Comment on attachment 445169 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=445169&action=review >> Source/WebCore/platform/graphics/filters/FilterImage.cpp:60 >> +IntRect FilterImage::relativeAbsoluteImageRect(const FilterImage& origin) const > > "relativeAbsoluteImageRect" is a confusing name for me, since "relative" and "absolute" are opposites. I'm struggling to come up with a good name -- something like "absoluteImageRectRelativeToFilterImage"? Not sure. Maybe there could be a better name if the "this" and argument were the other way around? We agreed on naming it absoluteImageRectRelativeTo() at least for now.
EWS
Comment 5 2021-11-25 23:53:46 PST
Committed r286172 (244555@main): <https://commits.webkit.org/244555@main> All reviewed patches have been landed. Closing bug and clearing flags on attachment 445170 [details].
Radar WebKit Bug Importer
Comment 6 2021-11-25 23:54:25 PST
Note You need to log in before you can comment on or make changes to this bug.