Bug 233415

Summary: [JSC] Move m_incomingPolymorphicCalls out of CodeBlock::JITData
Product: WebKit Reporter: Yusuke Suzuki <ysuzuki>
Component: New BugsAssignee: Yusuke Suzuki <ysuzuki>
Status: RESOLVED FIXED    
Severity: Normal CC: annulen, benjamin, cdumez, cmarcelo, darin, ews-watchlist, gyuyoung.kim, keith_miller, mark.lam, msaboff, ryuan.choi, saam, sergio, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch
ews-feeder: commit-queue-
Patch mark.lam: review+

Description Yusuke Suzuki 2021-11-21 23:21:45 PST
[JSC] Move m_incomingPolymorphicCalls out of CodeBlock::JITData
Comment 1 Yusuke Suzuki 2021-11-21 23:23:28 PST
Created attachment 444946 [details]
Patch
Comment 2 Yusuke Suzuki 2021-11-21 23:28:06 PST
Created attachment 444947 [details]
Patch
Comment 3 Yusuke Suzuki 2021-11-21 23:53:26 PST
Created attachment 444949 [details]
Patch
Comment 4 Radar WebKit Bug Importer 2021-11-28 23:22:18 PST
<rdar://problem/85801379>
Comment 5 Mark Lam 2021-11-29 10:01:18 PST
Comment on attachment 444949 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=444949&action=review

Nice.  r=me

> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:96
> +

Can you add the following here?
    EXPECT_TRUE(!first->isOnList());
    EXPECT_TRUE(!second->isOnList());
    EXPECT_TRUE(!third->isOnList());
    EXPECT_TRUE(!fourth->isOnList());

> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:100
> +TEST(WTF_SentinelLinkedList, RemoveAll)

I think `Remove` is a better name for this test (instead of `RemoveAll`) since it's testing the `remove` method.

> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:115
> +}

Can you add an `EXPECT_TRUE(i == 10);` here?
Comment 6 Darin Adler 2021-11-29 10:03:53 PST
Comment on attachment 444949 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=444949&action=review

>> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:115
>> +}
> 
> Can you add an `EXPECT_TRUE(i == 10);` here?

Or more idiomatically:

    EXPECT_EQ(10, i);

> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:132
> +    EXPECT_EQ(list.begin()->value(), 0);

These are all backward. The macro writes out error messages assuming that the expected value is first and the expression is second. You’ll notice this in failing tests, so it’s slightly more elegant to do it in the order the macro exprects.
Comment 7 Yusuke Suzuki 2021-11-29 11:29:03 PST
Comment on attachment 444949 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=444949&action=review

Thank you!

>> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:96
>> +
> 
> Can you add the following here?
>     EXPECT_TRUE(!first->isOnList());
>     EXPECT_TRUE(!second->isOnList());
>     EXPECT_TRUE(!third->isOnList());
>     EXPECT_TRUE(!fourth->isOnList());

Nice. Added.

>> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:100
>> +TEST(WTF_SentinelLinkedList, RemoveAll)
> 
> I think `Remove` is a better name for this test (instead of `RemoveAll`) since it's testing the `remove` method.

Make sense. Changed.

>>> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:115
>>> +}
>> 
>> Can you add an `EXPECT_TRUE(i == 10);` here?
> 
> Or more idiomatically:
> 
>     EXPECT_EQ(10, i);

Sounds good. Added.

>> Tools/TestWebKitAPI/Tests/WTF/SentinelLinkedList.cpp:132
>> +    EXPECT_EQ(list.begin()->value(), 0);
> 
> These are all backward. The macro writes out error messages assuming that the expected value is first and the expression is second. You’ll notice this in failing tests, so it’s slightly more elegant to do it in the order the macro exprects.

Good catch! Changed :)
Comment 8 Yusuke Suzuki 2021-11-29 11:52:01 PST
Committed r286248 (244611@main): <https://commits.webkit.org/244611@main>