Bug 232267

Summary: Regression (r284742): [ macOS wk2 Release ] imported/w3c/web-platform-tests/speech-api/SpeechSynthesis-speak-events.html is failing
Product: WebKit Reporter: ayumi_kojima
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: andresg_22, cfleizach, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=227501

Description ayumi_kojima 2021-10-25 13:54:55 PDT
imported/w3c/web-platform-tests/speech-api/SpeechSynthesis-speak-events.html

Is constantly failing on BigSur wk2 Release and flaky on Catalina wk2 Release.

History: https://results.webkit.org/?suite=layout-tests&test=imported%2Fw3c%2Fweb-platform-tests%2Fspeech-api%2FSpeechSynthesis-speak-events.html

Result page: https://build.webkit.org/results/Apple-BigSur-Release-AppleSilicon-WK2-Tests/r284799%20(4955)/results.html

Diff:

--- /Volumes/Data/worker/bigsur-release-applesilicon-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/speech-api/SpeechSynthesis-speak-events-expected.txt
+++ /Volumes/Data/worker/bigsur-release-applesilicon-tests-wk2/build/layout-test-results/imported/w3c/web-platform-tests/speech-api/SpeechSynthesis-speak-events-actual.txt
@@ -1,4 +1,6 @@
+
+Harness Error (TIMEOUT), message = null
 
 FAIL speechSynthesis.speak() fires start and end events with empty utterance assert_true: Not expecting event, but got end event expected true got false
-PASS speechSynthesis.speak() fires start and end events
+TIMEOUT speechSynthesis.speak() fires start and end events Test timed out

The test was marked as pass/fail on iOS in Bug 227501
Comment 1 Radar WebKit Bug Importer 2021-10-25 13:55:22 PDT
<rdar://problem/84629268>
Comment 2 ayumi_kojima 2021-10-25 13:56:57 PDT
According to the history, it looks like the test started failing on macOS at https://trac.webkit.org/changeset/284742/webkit
Comment 3 ayumi_kojima 2021-10-25 14:35:05 PDT
Reverted the change in https://trac.webkit.org/changeset/284822/webkit