Bug 232004

Summary: Captured WebGL canvas uses IOKit in WebProcess
Product: WebKit Reporter: Kimmo Kinnunen <kkinnunen>
Component: WebGLAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: bfulgham, dino, kbr, kkinnunen, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Local Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on: 232879    
Bug Blocks: 217211    

Description Kimmo Kinnunen 2021-10-19 23:26:12 PDT
Captured WebGL canvas uses IOKit in WebProcess

E.g. GraphicsContextGL::paintCompositedResultsToMediaSample transfers CVPixelBuffer objects as IOSurfaces.
Solution could be to implement remote version of MediaSample interface.
Comment 1 Radar WebKit Bug Importer 2021-10-19 23:33:12 PDT
<rdar://problem/84449714>
Comment 2 Brent Fulgham 2022-06-23 14:42:40 PDT

*** This bug has been marked as a duplicate of bug 236496 ***