Bug 231714

Summary: [ iOS15 ] fast/scrolling/ios/click-events-during-momentum-scroll-in-overflow.html is a flaky timeout
Product: WebKit Reporter: Eric Hutchison <ehutchison>
Component: ScrollingAssignee: Nobody <webkit-unassigned>
Status: RESOLVED CONFIGURATION CHANGED    
Severity: Normal CC: bfulgham, ehutchison, simon.fraser, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Eric Hutchison 2021-10-13 17:50:30 PDT
fast/scrolling/ios/click-events-during-momentum-scroll-in-overflow.html

is a flaky timeout on iOS15

History: https://results.webkit.org/?suite=layout-tests&test=fast%2Fscrolling%2Fios%2Fclick-events-during-momentum-scroll-in-overflow.html

Build: https://build.webkit.org/#/builders/268/builds/151

Results: https://build.webkit.org/results/Apple-iOS-15-Simulator-Release-WK2-Tests/r284090%20(151)/results.html

Diff:
--- /Volumes/Data/worker/ios-simulator-15-release-tests-wk2/build/layout-test-results/fast/scrolling/ios/click-events-during-momentum-scroll-in-overflow-expected.txt
+++ /Volumes/Data/worker/ios-simulator-15-release-tests-wk2/build/layout-test-results/fast/scrolling/ios/click-events-during-momentum-scroll-in-overflow-actual.txt
@@ -1,10 +1,8 @@
+FAIL: Timed out waiting for notifyDone to be called
+
 Verifies that tapping a subscrollable region during momentum scrolling does not dispatch click events. To run the test manually, swipe up on the black box to scroll it; while scrolling, tap the scrollable area to interrupt scrolling. The scrollable area should not observe any click events.
 
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS scroller.scrollTop passed 500
-PASS successfullyParsed is true
 
-TEST COMPLETE
-

Unable to reproduce
Comment 1 Radar WebKit Bug Importer 2021-10-13 17:51:05 PDT
<rdar://problem/84225904>
Comment 2 Eric Hutchison 2021-10-13 17:56:26 PDT
Updated test expectations at https://trac.webkit.org/changeset/284140/webkit
Comment 3 Eric Hutchison 2021-10-29 13:45:02 PDT
Test continues to timeout on iOS15 queues. Still unable to reproduce locally.
Comment 4 Brent Fulgham 2022-06-23 14:40:52 PDT
Ryan Haddad confirmed this is resolved as of 5/25/2022.