Bug 231372

Summary: [ Mac EWS ] http/tests/xmlhttprequest tests are flaky with "Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'This task has already been stopped'"
Product: WebKit Reporter: ayumi_kojima
Component: New BugsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: ap, bfulgham, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Mac (Apple Silicon)   
OS: Unspecified   
Attachments:
Description Flags
Crash log
none
Test lists none

Description ayumi_kojima 2021-10-07 10:23:23 PDT
http/tests/xmlhttprequest/access-control-response-with-body.html

Is flaky crashing on macOS-AppleSilicon-Big-Sur-Debug-WK2-Tests-EWS.

The crash is not seen in the open source directory: https://results.webkit.org/?suite=layout-tests&test=http%2Ftests%2Fxmlhttprequest%2Faccess-control-response-with-body.html

Result page: https://ews-build.s3-us-west-2.amazonaws.com/macOS-AppleSilicon-Big-Sur-Debug-WK2-Tests-EWS/r440471-13896/results.html

Stderr:

2021-10-07 05:17:12.767 WebKitTestRunner[63713:11115910] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'This task has already been stopped'
*** First throw call stack:
(
	0   CoreFoundation                      0x0000000198964c78 __exceptionPreprocess + 240
	1   libobjc.A.dylib                     0x000000019868d0a8 objc_exception_throw + 60
	2   CoreFoundation                      0x0000000198964ac4 +[NSException exceptionWithName:reason:userInfo:] + 0
	3   WebKit                              0x000000010eab4718 _ZL25raiseExceptionIfNecessaryN6WebKit16WebURLSchemeTask13ExceptionTypeE + 116
	4   WebKit                              0x000000010eab48d8 -[WKURLSchemeTaskImpl didReceiveResponse:] + 156
	5   WebKit                              0x000000010edccb08 __66-[WKInspectorResourceURLSchemeHandler webView:startURLSchemeTask:]_block_invoke + 1716
	6   Foundation                          0x000000019966df50 __NSBLOCKOPERATION_IS_CALLING_OUT_TO_A_BLOCK__ + 24
	7   Foundation                          0x000000019966ddf8 -[NSBlockOperation main] + 104
	8   Foundation                          0x000000019966dd88 __NSOPERATION_IS_INVOKING_MAIN__ + 24
	9   Foundation                          0x000000019966cfc8 -[NSOperation start] + 808
	10  Foundation                          0x000000019966cc98 __NSOPERATIONQUEUE_IS_STARTING_AN_OPERATION__ + 24
	11  Foundation                          0x000000019966cb4c __NSOQSchedule_f + 184
	12  libdispatch.dylib                   0x0000000198636128 _dispatch_call_block_and_release + 32
	13  libdispatch.dylib                   0x0000000198637ec0 _dispatch_client_callout + 20
	14  libdispatch.dylib                   0x00000001986497b0 _dispatch_root_queue_drain + 688
	15  libdispatch.dylib                   0x0000000198649e90 _dispatch_worker_thread2 + 112
	16  libsystem_pthread.dylib             0x00000001987e3860 _pthread_wqthread + 216
	17  libsystem_pthread.dylib             0x00000001987e25d4 start_wqthread + 8
)
libc++abi: terminating with uncaught exception of type NSException
Comment 1 ayumi_kojima 2021-10-07 10:24:20 PDT
Created attachment 440508 [details]
Crash log
Comment 2 Radar WebKit Bug Importer 2021-10-07 10:24:44 PDT
<rdar://problem/83987742>
Comment 3 ayumi_kojima 2021-10-07 10:32:59 PDT
Marked test expectations to speed up EWS: https://trac.webkit.org/changeset/283719/webkit
Comment 4 ayumi_kojima 2021-10-08 09:10:22 PDT
Observing some http/tests/xmlhttprequest are also crashing on the BigSur EWS. Like Ryan suggested, this must be order dependent.
Comment 5 ayumi_kojima 2021-10-08 09:25:38 PDT
the same crash is also seen in macOS-Catalina-Release-WK2-Tests-EWS: https://ews-build.webkit.org/#/builders/59/builds/17475
Comment 6 ayumi_kojima 2021-10-08 13:42:48 PDT
Tried to reproduce with the attached test list (run-webkit-tests --test-list <test-list.txt> --child-process 1 --exit-after-n-crashes-or-timeouts 1000 --exit-after-n-failures 1000 --no-build --no-show-results --no-new-test-results --clobber-old-results --debug --debug-rwt-logging), but I was not able to reproduce the crash.

Tried at TOT on BigSur twice. http/tests/xmlhttprequest/redirections-and-user-headers.html failed both times but this test does't seem to have ever failed on macOS on the open source and EWS test runs. I don't know why it failed locally.
Comment 7 ayumi_kojima 2021-10-08 13:43:21 PDT
Created attachment 440665 [details]
Test lists
Comment 8 Brent Fulgham 2022-06-23 14:30:45 PDT

*** This bug has been marked as a duplicate of bug 237484 ***