Bug 231141

Summary: [GTK] Tools/Scripts/update-webkitgtk-libs flatpak remote failure on Ubuntu 20
Product: WebKit Reporter: wei.justin.a
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED FIXED    
Severity: Normal CC: pnormand
Priority: P2    
Version: WebKit Local Build   
Hardware: PC   
OS: Linux   

Description wei.justin.a 2021-10-03 12:06:18 PDT
Hi,

I am trying to build the WebKit GTK+ Port on a clean Ubuntu 20 VirtualBox.
Running Tools/gtk/install-dependencies works great but-

The command Tools/Scripts/update-webkitgtk-libs seems to not find the correct flatpak remote.

---------------------------------------
Updating Flatpak Release environment
Looking for updates…
Nothing to do.
Installing from webkit-sdk org.webkit.Platform x86_64 21.08
Looking for matches…
error: Unable to load summary from remote webkit-sdk: renameat: Text file busy

The following command returned a non-zero exit status: flatpak install --user --assumeyes webkit-sdk org.webkit.Platform --reinstall 21.08
Output: None
Died at Tools/Scripts/update-webkitgtk-libs line 28.
---------------------------------------


When I manually run the command that fails, it seems like a flatpak remote problem:
flatpak install --user --assumeyes webkit-sdk org.webkit.Platform --reinstall 21.08
Looking for matches…
error: No remote refs found similar to ‘webkit-sdk’


Indeed, I can't find webkit-sdk via flatpak search:
flatpak search webkit-sdk
No matches found


I've also tried doing this on a Linux Mint (Cinnamon) VirtualBox as well with the same results.
Comment 1 Philippe Normand 2021-10-13 06:04:09 PDT
rm -fr WebKitBuild/UserFlatpak and try again?
Comment 2 wei.justin.a 2021-10-13 08:43:21 PDT
This was an error with trying to store the repo on a VM Box shared folder. Recloning the repository on the guest filesystem worked. Thanks