Bug 230752

Summary: REGRESSION (Safari 15): Not sending over media after the initial negotiation
Product: WebKit Reporter: Rabin <ravarghe>
Component: WebRTCAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Major CC: alex, daniel.stabel, dan, dom, Evan.Roberts, francesco.durighetto, hleguern, info, markus.plesner, mawojtcz, oanguenot, streambot, teodor.atroshenko, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: All   
OS: Unspecified   

Description Rabin 2021-09-24 09:02:20 PDT
On Safari 15, Our product is encountering an issue, where the local media stream captured from device when trying to be sent over to remote, the remote party doesn't receive the media.
But the same product works fine when we use Safari 13 / Safari 14 / Any other browser (eg: Chrome/Firefox).
Whether this is an issue with Safari 15 or with the version of WebRTC used therein we aren't sure.

The normal flow which was working so far on a high level (older Safari version and other browsers)
join page -> create camera stream for self-view(preview) -> join (negotiation) -> pass camera stream 

For making it work with safari 15, we are had to pass camera stream again after joining (negotiation)
join page -> create camera stream for self-view(preview) -> join (negotiation) -> capture camera stream again and pass the recent camera stream.

Let us know , If there is any change that needs to be addressed from our side with respect to any recent change that had gone in Safari 15 (that was not available in older version).
Comment 1 Rabin 2021-09-24 09:18:16 PDT
We are seeing this often in console logs as well : A MediaStreamTrack ended due to a capture failure while using Safari 15
Comment 2 Radar WebKit Bug Importer 2021-09-26 14:08:44 PDT
<rdar://problem/83552503>
Comment 3 Rabin 2021-09-28 03:34:46 PDT
Since this bug is marked as Regression.
In which release of safari can we expect a fix for this.
Comment 4 youenn fablet 2021-09-28 04:27:44 PDT
Hi Rabin, do you have a repro case, something like a fiddle?
Is the issue always happening when you hit 'A MediaStreamTrack ended due to a capture failure'?
Comment 5 Rabin 2021-10-03 22:14:24 PDT
Hi Youenn,
Just updating here as well,
The issue which we face is not always in relation to 'A MediaStreamTrack ended due to a capture failure'.

logs which we could collect, shared it, to you over mail.
Comment 6 Olivier Anguenot 2021-10-06 04:31:32 PDT
Hi Youenn,

If you need a fiddle, you can test with the WebRTC sample here:
https://webrtc.github.io/samples/src/content/peerconnection/pc1/

I tested on my own with an Ipad Pro M1 with IOS 15.0.1 and the result is a black screen on the receiver side.

It was working before upgrading the Ipad to IOS 15.x

I tried to remove the support of some experimental features in Safari but without success.

Thanks in advance
Comment 7 Alessandro Amirante 2021-10-08 03:06:26 PDT
We're having the same kind of issue with Safari 15 on Big Sur. 

We get the "A MediaStreamTrack ended due to a capture failure" error when we try a getUserMedia for audio. We can reproduce the issue consistently with:

https://webrtc.github.io/samples/src/content/getusermedia/volume/

The same audio gUM succeeds in Chrome instead. Video gUM works fine as well.
Comment 8 Teodor 2021-10-08 16:15:33 PDT
Same problem here. Same circumstances. Same repro with WebRTC samples.
Comment 9 Olivier Anguenot 2021-10-12 00:24:28 PDT
Hello,

Seems that there is no more issue on my side with IOS 15.0.2 and the sample https://webrtc.github.io/samples/src/content/peerconnection/pc1/

Could someone else confirm that with that version, problem is solved ?

Thanks in advance
Comment 10 Markus 2021-11-16 08:30:43 PST
Still not fixed in 15.2 Beta 2
Comment 11 hleguern 2022-01-24 15:49:45 PST
Hi folks,
Do we know if this issue is fixed now?
Comment 12 Daniel Stabel 2022-01-27 06:37:42 PST
Hello, 

we had this problem for joining Meetings on our CMS, since iOS 15 and the bug from Cisco (https://bst.cloudapps.cisco.com/bugsearch/bug/CSCvz76478) is referenced / based on this Bug 230752 here. 
Now, I have installed iOS 15.3 on my iPhones and it seems to work again. 

Can anyone confirm that this is fixed with iOS 15.3 ?
Comment 13 Jeremy Harris 2022-01-27 17:15:26 PST
"Can anyone confirm that this is fixed with iOS 15.3?"

I can at least confirm that Safari on Mac 15.2 was not initially sending streams of audio or video type the first time sending them, and after updating to 15.3 the issue seems resolved.
Comment 14 youenn fablet 2022-01-28 00:49:10 PST

*** This bug has been marked as a duplicate of bug 234296 ***
Comment 15 Markus 2022-01-31 08:54:29 PST
I can confirm that this Safari 15 isssue is fixed on iPadOS Version 15.3, iOS 15.2 and macOS 15.2 . Many thanks!
Comment 16 Francesco Durighetto (kekkokk) 2022-02-08 03:50:51 PST
I think we are mixing two different:
- one related to peerconnection that has been fixed
- the other one related to audio capture (A MediaStreamTrack ended due to a capture failure) which is still not fixed in 15.3 to me.
If you continue noticing this console log please CC to bug: https://bugs.webkit.org/show_bug.cgi?id=233473