Bug 23075

Summary: REGRESSION (r39164): Discarding quantifier on assertion gives incorrect result
Product: WebKit Reporter: Lasse Reichstein Holst Nielsen <lrn>
Component: JavaScriptCoreAssignee: Geoffrey Garen <ggaren>
Status: RESOLVED FIXED    
Severity: Normal CC: barraclough, ggaren
Priority: P2 Keywords: HasReduction, InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: PC   
OS: All   
Attachments:
Description Flags
patch zwarich: review+

Description Lasse Reichstein Holst Nielsen 2009-01-02 06:00:51 PST
The follwing javascript expression 
 /^(?=a)?b$/.test("b")
evaluates to false since changeset 39164. It should give true, both according to the ECMAScript specification and, e.g., what Firefox does.
Comment 1 Mark Rowe (bdash) 2009-01-02 12:43:44 PST
<rdar://problem/6471394>
Comment 2 Geoffrey Garen 2009-01-15 23:10:12 PST
Created attachment 26785 [details]
patch
Comment 3 Cameron Zwarich (cpst) 2009-01-15 23:49:05 PST
Comment on attachment 26785 [details]
patch

r=me, although you should also include the Bugzilla URL in the ChangeLogs.
Comment 4 Geoffrey Garen 2009-01-16 00:02:21 PST
Committed revision 39963.