Bug 230701

Summary: [ Catalina Debug wk1 ] performance-api/performance-observer-callback-after-gc.html is a flaky crash (no data while reading stdout for the server process)
Product: WebKit Reporter: Eric Hutchison <ehutchison>
Component: Tools / TestsAssignee: Nobody <webkit-unassigned>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: cdumez, ehutchison, jbedard, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   

Description Eric Hutchison 2021-09-23 11:10:10 PDT
performance-api/performance-observer-callback-after-gc.html

is a flaky crash on Catalina Debug wk1.

History: https://results.webkit.org/?suite=layout-tests&test=performance-api/performance-observer-callback-after-gc.html

Results: https://ews-build.webkit.org/#/builders/56/builds/15864

Diff: 

08:08:38.235 727 worker/9 worker/9 performance-api/performance-observer-callback-after-gc.html crashed, (no stderr)

Unable to reproduce results locally due to lack of access to tools.
Comment 1 Radar WebKit Bug Importer 2021-09-23 11:11:55 PDT
<rdar://problem/83456833>
Comment 2 Eric Hutchison 2021-09-23 11:22:37 PDT
Updated test expectations at https://trac.webkit.org/changeset/282974/webkit
Comment 3 Alexey Proskuryakov 2021-09-25 13:39:54 PDT
08:06:36.735 727 worker/9 performance-api/performance-observer-basic.html passed
08:06:38.227 727 worker/9 This test marked as a crash because of no data while reading stdout for the server process.
08:06:38.228 727 worker/9 This test marked as a crash because of no data while reading stdout for the server process.
08:08:38.235 727 worker/9 worker/9 performance-api/performance-observer-callback-after-gc.html crashed, (no stderr)
08:08:38.236 727 worker/9 killing driver
08:08:38.242 727 worker/9 performance-api/performance-observer-callback-after-gc.html failed:
08:08:38.242 727 worker/9 DumpRenderTree crashed [pid=841]
Comment 4 Eric Hutchison 2021-10-04 15:13:52 PDT
Removed expectations and closing bug.
Comment 5 Chris Dumez 2021-10-06 12:23:42 PDT
The crash was:
Application Specific Information:
CRASHING TEST: performance-api/performance-observer-callback-after-gc.html

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.apple.JavaScriptCore      	0x00000001142ec546 bmalloc::Heap::decommitLargeRange(std::__1::unique_lock<bmalloc::Mutex>&, bmalloc::LargeRange&, bmalloc::BulkDecommit&) + 486 (Heap.cpp:146)
1   com.apple.JavaScriptCore      	0x00000001142ece1c bmalloc::Heap::scavenge(std::__1::unique_lock<bmalloc::Mutex>&, bmalloc::BulkDecommit&, unsigned long&) + 1548 (Heap.cpp:190)
2   com.apple.JavaScriptCore      	0x00000001142fd0cd bmalloc::Scavenger::scavenge() + 205 (Scavenger.cpp:205)
3   com.apple.JavaScriptCore      	0x00000001142e0796 bmalloc::api::scavenge() + 134 (bmalloc.cpp:145)
4   com.apple.JavaScriptCore      	0x00000001141b1e89 WTF::releaseFastMallocFreeMemory() + 9 (FastMalloc.cpp:639)
5   com.apple.WebCore             	0x0000000138251055 WebCore::GCController::garbageCollectNow() + 117 (GCController.cpp:99)
6   com.apple.WebKitLegacy        	0x000000010ed9af5d +[WebCoreStatistics garbageCollectJavaScriptObjects] + 29 (WebCoreStatistics.mm:109)
7   DumpRenderTree                	0x000000010aaa67f3 GCController::collect() const + 35 (GCControllerMac.mm:39)
8   DumpRenderTree                	0x000000010aaa66c6 collectCallback(OpaqueJSContext const*, OpaqueJSValue*, OpaqueJSValue*, unsigned long, OpaqueJSValue const* const*, OpaqueJSValue const**) + 54 (GCController.cpp:40)
9   com.apple.JavaScriptCore      	0x000000011496cc5a long long JSC::APICallbackFunction::callImpl<JSC::JSCallbackFunction>(JSC::JSGlobalObject*, JSC::CallFrame*) + 618 (APICallbackFunction.h:61)
10  com.apple.JavaScriptCore      	0x000000011496067d JSC::callJSCallbackFunction(JSC::JSGlobalObject*, JSC::CallFrame*) + 29 (JSCallbackFunction.cpp:42)
11  ???                           	0x0000579eb5801027 0 + 96339161518119
12  com.apple.JavaScriptCore      	0x00000001148322fe llint_entry + 145028
13  com.apple.JavaScriptCore      	0x00000001148323ae llint_entry + 145204
14  com.apple.JavaScriptCore      	0x000000011480e980 vmEntryToJavaScript + 289
15  com.apple.JavaScriptCore      	0x00000001157edd7b JSC::JITCode::execute(JSC::VM*, JSC::ProtoCallFrame*) + 235 (JITCodeInlines.h:42)
16  com.apple.JavaScriptCore      	0x00000001157ee557 JSC::Interpreter::executeCall(JSC::JSGlobalObject*, JSC::JSObject*, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 1847 (Interpreter.cpp:900)
17  com.apple.JavaScriptCore      	0x0000000115bdc9dd JSC::call(JSC::JSGlobalObject*, JSC::JSValue, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&) + 221 (CallData.cpp:57)
18  com.apple.JavaScriptCore      	0x0000000115bdcabf JSC::call(JSC::JSGlobalObject*, JSC::JSValue, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&, WTF::NakedPtr<JSC::Exception>&) + 207 (CallData.cpp:64)
19  com.apple.JavaScriptCore      	0x0000000115bdcda2 JSC::profiledCall(JSC::JSGlobalObject*, JSC::ProfilingReason, JSC::JSValue, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&, WTF::NakedPtr<JSC::Exception>&) + 130 (CallData.cpp:85)
20  com.apple.WebCore             	0x000000013825a66e WebCore::JSExecState::profiledCall(JSC::JSGlobalObject*, JSC::ProfilingReason, JSC::JSValue, JSC::CallData const&, JSC::JSValue, JSC::ArgList const&, WTF::NakedPtr<JSC::Exception>&) + 110 (JSExecState.h:73)
21  com.apple.WebCore             	0x0000000138327e21 WebCore::ScheduledAction::executeFunctionInContext(JSC::JSGlobalObject*, JSC::JSValue, WebCore::ScriptExecutionContext&) + 1009 (ScheduledAction.cpp:121)
22  com.apple.WebCore             	0x0000000138327845 WebCore::ScheduledAction::execute(WebCore::Document&) + 277 (ScheduledAction.cpp:141)
23  com.apple.WebCore             	0x0000000138327703 WebCore::ScheduledAction::execute(WebCore::ScriptExecutionContext&) + 67 (ScheduledAction.cpp:86)
24  com.apple.WebCore             	0x00000001398c3b67 WebCore::DOMTimer::fired() + 1063 (DOMTimer.cpp:339)
25  com.apple.WebCore             	0x0000000139c165b4 WebCore::ThreadTimers::sharedTimerFiredInternal() + 644 (ThreadTimers.cpp:127)
26  com.apple.WebCore             	0x0000000139c20601 WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0::operator()() const + 33 (ThreadTimers.cpp:67)
27  com.apple.WebCore             	0x0000000139c2058e WTF::Detail::CallableWrapper<WebCore::ThreadTimers::setSharedTimer(WebCore::SharedTimer*)::$_0, void>::call() + 30 (Function.h:53)
28  com.apple.WebCore             	0x0000000135810322 WTF::Function<void ()>::operator()() const + 130 (Function.h:82)
29  com.apple.WebCore             	0x0000000139bbcdbb WebCore::MainThreadSharedTimer::fired() + 139 (MainThreadSharedTimer.cpp:84)
30  com.apple.WebCore             	0x0000000139ca4976 WebCore::timerFired(__CFRunLoopTimer*, void*) + 38 (MainThreadSharedTimerCF.cpp:86)
31  com.apple.CoreFoundation      	0x00007fff345487f9 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
32  com.apple.CoreFoundation      	0x00007fff3454835f __CFRunLoopDoTimer + 859
33  com.apple.CoreFoundation      	0x00007fff34547e47 __CFRunLoopDoTimers + 322
34  com.apple.CoreFoundation      	0x00007fff3452cbea __CFRunLoopRun + 1871
35  com.apple.CoreFoundation      	0x00007fff3452be3e CFRunLoopRunSpecific + 462
36  DumpRenderTree                	0x000000010aa5d774 runTest(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&) + 3348 (DumpRenderTree.mm:1963)
37  DumpRenderTree                	0x000000010aa5c9ba runTestingServerLoop() + 218 (DumpRenderTree.mm:1077)
38  DumpRenderTree                	0x000000010aa5c1f8 dumpRenderTree(int, char const**) + 616 (DumpRenderTree.mm:1191)
39  DumpRenderTree                	0x000000010aa5e322 DumpRenderTreeMain(int, char const**) + 114 (DumpRenderTree.mm:1308)
40  DumpRenderTree                	0x000000010ab4acf2 main + 34 (DumpRenderTreeMain.mm:34)
41  libdyld.dylib                 	0x00007fff6e596cc9 start + 1
Comment 6 Eric Hutchison 2021-11-03 12:58:36 PDT

*** This bug has been marked as a duplicate of bug 231684 ***