Bug 229665

Summary: REGRESSION(r277763): [Debug][GLib] fast/mediastream timeouts
Product: WebKit Reporter: Philippe Normand <pnormand>
Component: WebKitGTKAssignee: Philippe Normand <pnormand>
Status: RESOLVED FIXED    
Severity: Normal CC: bugs-noreply, calvaris, eric.carlson, ews-watchlist, glenn, hta, jer.noble, philipj, sergio, tommyw
Priority: P2    
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=225976
Attachments:
Description Flags
Patch none

Description Philippe Normand 2021-08-30 02:16:29 PDT
The following tests are timing out only in Debug, since r277763 (see for instance https://results.webkit.org/?suite=layout-tests&test=fast%2Fmediastream%2Fget-user-media-device-id.html ):

  fast/mediastream/constraint-intrinsic-size.html [ Timeout ]
  fast/mediastream/get-user-media-device-id.html [ Timeout ]
  fast/mediastream/getDisplayMedia-frame-rate.html [ Timeout ]
  fast/mediastream/getDisplayMedia-max-constraints1.html [ Timeout ]
  fast/mediastream/getDisplayMedia-max-constraints2.html [ Timeout ]
  fast/mediastream/getDisplayMedia-max-constraints3.html [ Timeout ]
  fast/mediastream/screencapture-user-gesture.html [ Timeout ]
  webrtc/h264-high.html [ Timeout ]

I suspect bad handling of the PixelBuffer in the samples created by the mock video source... Or an issue with the Cairo backend.
Comment 1 Philippe Normand 2021-08-30 02:27:08 PDT
Expectations updated in r281753.
Comment 2 Philippe Normand 2021-08-31 09:15:45 PDT
Created attachment 436893 [details]
Patch
Comment 3 EWS 2021-09-02 07:50:11 PDT
Committed r281921 (241230@main): <https://commits.webkit.org/241230@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 436893 [details].