Bug 229532

Summary: REGRESSION (r281516): [AppleSilicon WK2] fast/loader/reload-zero-byte-plugin.html is timing out
Product: WebKit Reporter: Ryan Haddad <ryanhaddad>
Component: New BugsAssignee: Chris Dumez <cdumez>
Status: RESOLVED FIXED    
Severity: Normal CC: cdumez, webkit-bot-watchers-bugzilla, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://bugs.webkit.org/show_bug.cgi?id=229203
Attachments:
Description Flags
sample from bot
none
WIP patch
none
WIP patch none

Description Ryan Haddad 2021-08-25 19:45:50 PDT
fast/loader/reload-zero-byte-plugin.html has started consistently timing out with no output on Big Sur WK2 bots

https://results.webkit.org/?suite=layout-tests&test=fast%2Floader%2Freload-zero-byte-plugin.html
Comment 1 Ryan Haddad 2021-08-25 19:51:18 PDT
Created attachment 436458 [details]
sample from bot
Comment 2 Radar WebKit Bug Importer 2021-08-25 19:51:46 PDT
<rdar://problem/82370692>
Comment 3 Ryan Haddad 2021-08-25 19:55:27 PDT
I cannot reproduce this with a build of r281515, but I can with r281516.
Comment 4 Ryan Haddad 2021-08-25 20:02:37 PDT
This is only occurring on Apple Silicon bots, and my machine is also an AS one.
Comment 5 Chris Dumez 2021-08-25 20:07:37 PDT
Committed r281611 (240967@main): <https://commits.webkit.org/240967@main>
Comment 6 Chris Dumez 2021-08-25 20:07:58 PDT
Reopening since I merely skipped the test for now.
Comment 7 Chris Dumez 2021-08-25 20:20:35 PDT
Created attachment 436462 [details]
WIP patch

Patch for EWS since I don't have an Apple Silicon device handy.
Comment 8 Ryan Haddad 2021-08-25 21:27:28 PDT
(In reply to Chris Dumez from comment #7)
> Created attachment 436462 [details]
> WIP patch
> 
> Patch for EWS since I don't have an Apple Silicon device handy.
This did not resolve the issue for me locally.
Comment 9 Chris Dumez 2021-08-26 07:27:03 PDT
(In reply to Ryan Haddad from comment #8)
> (In reply to Chris Dumez from comment #7)
> > Created attachment 436462 [details]
> > WIP patch
> > 
> > Patch for EWS since I don't have an Apple Silicon device handy.
> This did not resolve the issue for me locally.

Thanks for checking. Mac-AS-debug-wk2 is green so it seems I cannot rely on EWS after all?
Comment 10 Chris Dumez 2021-08-26 07:35:13 PDT
I built with UBSan and ran this test but there was nothing interesting in the output.
Comment 11 Chris Dumez 2021-08-26 07:38:05 PDT
Created attachment 436509 [details]
WIP patch
Comment 12 Ryan Haddad 2021-08-26 07:45:53 PDT
(In reply to Chris Dumez from comment #9)
> (In reply to Ryan Haddad from comment #8)
> > (In reply to Chris Dumez from comment #7)
> > > Created attachment 436462 [details]
> > > WIP patch
> > > 
> > > Patch for EWS since I don't have an Apple Silicon device handy.
> > This did not resolve the issue for me locally.
> 
> Thanks for checking. Mac-AS-debug-wk2 is green so it seems I cannot rely on
> EWS after all?
Hm, I’ll try another build..
Comment 13 Chris Dumez 2021-08-26 07:46:59 PDT
(In reply to Ryan Haddad from comment #12)
> (In reply to Chris Dumez from comment #9)
> > (In reply to Ryan Haddad from comment #8)
> > > (In reply to Chris Dumez from comment #7)
> > > > Created attachment 436462 [details]
> > > > WIP patch
> > > > 
> > > > Patch for EWS since I don't have an Apple Silicon device handy.
> > > This did not resolve the issue for me locally.
> > 
> > Thanks for checking. Mac-AS-debug-wk2 is green so it seems I cannot rely on
> > EWS after all?
> Hm, I’ll try another build..

Would you be able to provide me with the output of:
log stream --system | grep ProcessSwapping

When you run the test?

I am curious if process swapping is actually happening for some reason (it shouldn't in this test).
Comment 14 Chris Dumez 2021-08-26 10:04:16 PDT
Committed r281632 (240988@main): <https://commits.webkit.org/240988@main>
Comment 15 Chris Dumez 2021-08-26 12:29:21 PDT
"Big Sur E wk2 Release on Macmini9,1 with arm64" is green again. Still waiting on "Big Sur E wk2 Debug on Macmini9,1 with arm64" to process the patch but odds are the partial revert worked.