Bug 227956

Summary: [macOS] Add new entitlement to limit process to a single JIT region
Product: WebKit Reporter: Michael Saboff <msaboff>
Component: JavaScriptCoreAssignee: Michael Saboff <msaboff>
Status: RESOLVED FIXED    
Severity: Normal CC: ews-watchlist, keith_miller, mark.lam, sbarati, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch none

Description Michael Saboff 2021-07-14 09:43:59 PDT
With this entitlement, we match the iOS behavior.
Comment 1 Michael Saboff 2021-07-14 09:44:07 PDT
<rdar://problem/70817631>
Comment 2 Michael Saboff 2021-07-14 09:59:38 PDT
Created attachment 433508 [details]
Patch
Comment 3 EWS 2021-07-14 15:37:24 PDT
Committed r279927 (239674@main): <https://commits.webkit.org/239674@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 433508 [details].
Comment 4 Michael Saboff 2021-07-14 21:25:54 PDT
*** Bug 227083 has been marked as a duplicate of this bug. ***