Bug 226973

Summary: REGRESSION(r278734): broke jsc testapi
Product: WebKit Reporter: WebKit Commit Bot <commit-queue>
Component: New BugsAssignee: WebKit Commit Bot <commit-queue>
Status: RESOLVED FIXED    
Severity: Normal CC: aakash_jain, ews-watchlist, keith_miller, mark.lam, msaboff, sbarati, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Bug Depends on:    
Bug Blocks: 161942    
Attachments:
Description Flags
REVERT of r278734 none

Description WebKit Commit Bot 2021-06-14 07:56:15 PDT
https://trac.webkit.org/changeset/278734 broke the build:
broke jsc testapi

This is an automatic bug report generated by webkitbot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests fail.
Comment 1 WebKit Commit Bot 2021-06-14 07:56:22 PDT
Created attachment 431324 [details]
REVERT of r278734

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the revert will be successful.  This process takes approximately 15 minutes.

If you would like to land the revert faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 Aakash Jain 2021-06-14 09:14:02 PDT
EWS confirmed in https://ews-build.webkit.org/#/builders/1/builds/42267 that testapi passes after reverting r278734
Comment 3 EWS 2021-06-14 09:14:11 PDT
Committed r278830 (238781@main): <https://commits.webkit.org/238781@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 431324 [details].
Comment 4 Radar WebKit Bug Importer 2021-06-14 09:15:18 PDT
<rdar://problem/79291684>