Bug 226874

Summary: getDisplayMedia API doesn't work
Product: WebKit Reporter: olena.bezkrovna
Component: WebRTCAssignee: youenn fablet <youennf>
Status: RESOLVED FIXED    
Severity: Blocker CC: eric.carlson, ews-watchlist, glenn, hta, ivan.zahrodskyi, jer.noble, michiel, philipj, sergio, tommyw, webkit-bug-importer, youennf
Priority: P2 Keywords: InRadar
Version: Safari Technology Preview   
Hardware: Mac (Intel)   
OS: macOS 11   
Attachments:
Description Flags
black video instead of share
none
Patch none

Description olena.bezkrovna 2021-06-10 05:12:41 PDT
Created attachment 431063 [details]
black video instead of share

1. Go to sample https://webrtc.github.io/samples/src/content/getusermedia/getdisplaymedia/
2. Click Start and Allow the site to observe the screen
3. Observe the page

Actual result: Black video, no errors in the console
Expected result: Screen share should be displayed
Comment 1 Radar WebKit Bug Importer 2021-06-10 05:18:19 PDT
<rdar://problem/79134041>
Comment 2 youenn fablet 2021-06-10 05:20:27 PDT
Thanks Olena, I reproduced this issue on STP as well WebKit ToT.
Comment 3 youenn fablet 2021-06-10 05:37:04 PDT
Issue is due to frame rate decimation.
Comment 4 youenn fablet 2021-06-10 05:50:23 PDT
Created attachment 431065 [details]
Patch
Comment 5 EWS 2021-06-11 10:25:49 PDT
Committed r278764 (238724@main): <https://commits.webkit.org/238724@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 431065 [details].
Comment 6 youenn fablet 2021-07-06 02:13:30 PDT
*** Bug 227479 has been marked as a duplicate of this bug. ***