Bug 226634

Summary: [css-flexbox] Ignore item's main min/max sizes when computing the flex base size
Product: WebKit Reporter: Sergio Villar Senin <svillar>
Component: New BugsAssignee: Sergio Villar Senin <svillar>
Status: RESOLVED DUPLICATE    
Severity: Normal CC: changseok, darin, esprehn+autocc, ews-watchlist, fred.wang, glenn, kondapallykalyan, pdr, sam, webkit-bug-importer, zalan, zdobersek
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch zalan: review+

Description Sergio Villar Senin 2021-06-04 02:27:42 PDT
[css-flexbox] Ignore item's main min/max sizes when computing the flex base size
Comment 1 Sergio Villar Senin 2021-06-04 02:35:48 PDT
Created attachment 430563 [details]
Patch
Comment 2 Sergio Villar Senin 2021-06-04 02:38:36 PDT
Created attachment 430564 [details]
Patch
Comment 3 Radar WebKit Bug Importer 2021-06-11 02:28:15 PDT
<rdar://problem/79188711>
Comment 4 Sergio Villar Senin 2021-06-11 03:42:29 PDT
Gentle ping for reviewers
Comment 5 zalan 2021-06-24 20:08:12 PDT
Comment on attachment 430564 [details]
Patch

This is very unfortunate, but I don't see any easy way to do it given the current architecture. In LFC this would be super simple in a non-hackish way.
Comment 6 Sergio Villar Senin 2021-06-25 00:57:57 PDT
(In reply to zalan from comment #5)
> Comment on attachment 430564 [details]
> Patch
> 
> This is very unfortunate, but I don't see any easy way to do it given the
> current architecture. In LFC this would be super simple in a non-hackish way.

Right, I have exactly the same feeling. I am not happy at all with having to do it but I don't see it how to do it without having to replicate all the min/max code.
Comment 7 Sergio Villar Senin 2021-06-25 03:00:35 PDT
Somehow I messed it up and reported the same issue twice

*** This bug has been marked as a duplicate of bug 225590 ***