Bug 226020

Summary: $vm should have a function for checking if security assertions are enabled similar to $vm.assertEnabled
Product: WebKit Reporter: Tuomas Karkkainen <tuomas.webkit>
Component: JavaScriptCoreAssignee: Tuomas Karkkainen <tuomas.webkit>
Status: RESOLVED FIXED    
Severity: Normal CC: ews-watchlist, keith_miller, koivisto, mark.lam, msaboff, sbarati, tzagallo, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: Other   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
proposed patch
mark.lam: review+, ews-feeder: commit-queue-
rebased patch none

Description Tuomas Karkkainen 2021-05-20 07:23:48 PDT
$vm should have a function for checking if security assertions are enabled similar to $vm.assertEnabled
Comment 1 Tuomas Karkkainen 2021-05-20 07:46:57 PDT
Created attachment 429172 [details]
proposed patch
Comment 2 Mark Lam 2021-05-20 08:57:20 PDT
Comment on attachment 429172 [details]
proposed patch

r=me
Comment 3 EWS 2021-05-20 09:02:30 PDT
Tools/Scripts/svn-apply failed to apply attachment 429172 [details] to trunk.
Please resolve the conflicts and upload a new patch.
Comment 4 Radar WebKit Bug Importer 2021-05-27 07:24:17 PDT
<rdar://problem/78567619>
Comment 5 Tuomas Karkkainen 2021-06-07 03:15:46 PDT
Created attachment 430734 [details]
rebased patch
Comment 6 EWS 2021-06-07 04:12:01 PDT
Committed r278553 (238551@main): <https://commits.webkit.org/238551@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 430734 [details].