Bug 225172

Summary: [webkitcorepy] Allow user to specify interpreter used by autoinstall.py to install imported dependencies
Product: WebKit Reporter: Roy Reapor <rreapor>
Component: Tools / TestsAssignee: Roy Reapor <rreapor>
Status: RESOLVED FIXED    
Severity: Normal CC: jbedard, rreapor, webkit-bug-importer
Priority: P2 Keywords: InRadar
Version: WebKit Nightly Build   
Hardware: Unspecified   
OS: Unspecified   
Attachments:
Description Flags
Patch
none
Patch none

Description Roy Reapor 2021-04-28 16:46:24 PDT
Allow user to specify interpreter used by autoinstall.py to install imported dependencies.

Webapps that depend on a modules that are auto installed via 'autoinstall.py` could fail when ran under `uwsgi`. `uwsgi` overrides `sys.executable`. 

See https://github.com/unbit/uwsgi/issues/670
Comment 1 Radar WebKit Bug Importer 2021-04-28 16:47:09 PDT
<rdar://problem/77292151>
Comment 2 Roy Reapor 2021-04-28 16:59:43 PDT
Created attachment 427310 [details]
Patch
Comment 3 Jonathan Bedard 2021-04-28 17:14:35 PDT
Comment on attachment 427310 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=427310&action=review

> Tools/Scripts/libraries/webkitcorepy/setup.py:33
> +    version='0.5.10',

Need to bump this in Tools/Scripts/libraries/webkitcorepy/webkitcorepy/__init__.py too
Comment 4 Roy Reapor 2021-04-28 18:14:50 PDT
Created attachment 427321 [details]
Patch
Comment 5 EWS 2021-04-29 07:16:01 PDT
Committed r276772 (237156@main): <https://commits.webkit.org/237156@main>

All reviewed patches have been landed. Closing bug and clearing flags on attachment 427321 [details].