Bug 22244

Summary: Webkit nightly builds crash with Safari 3.2
Product: WebKit Reporter: Franck <drtifti>
Component: WebKit Misc.Assignee: Adam Roben (:aroben) <aroben>
Status: RESOLVED FIXED    
Severity: Major CC: aroben, jyrki.wahlstedt, sfalken
Priority: P2 Keywords: InRadar, Regression
Version: 528+ (Nightly build)   
Hardware: PC   
OS: Windows Vista   
Attachments:
Description Flags
Patch + ChangeLog mitz: review+

Description Franck 2008-11-13 16:05:14 PST
The latest available nightly build r38293 keeps crashing at start since I use Safari 3.2 on Vista
Comment 1 Franck 2008-11-13 16:08:31 PST
Vista's Error log: (sorry, german system)


  Problemereignisname:	APPCRASH
  Anwendungsname:	Safari.exe
  Anwendungsversion:	3.525.26.13
  Anwendungszeitstempel:	491915a1
  Fehlermodulname:	Safari.exe
  Fehlermodulversion:	3.525.26.13
  Fehlermodulzeitstempel:	491915a1
  Ausnahmecode:	c0000005
  Ausnahmeoffset:	000f8b41
  Betriebsystemversion:	6.0.6001.2.1.0.256.6
  Gebietsschema-ID:	1031
  Zusatzinformation 1:	487c
  Zusatzinformation 2:	8eba5207ca897dfdde296ea6f155626f
  Zusatzinformation 3:	bfad
  Zusatzinformation 4:	8c83680b112c52f1a25a99edd102f24d

Lesen Sie unsere Datenschutzrichtlinie:
  http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0407

Comment 2 Mark Rowe (bdash) 2008-11-13 19:01:06 PST
<rdar://problem/6370850>
Comment 3 Adam Roben (:aroben) 2008-11-13 20:23:28 PST
The problem here is that IWebViewPrivate::clearMainFrameName was added (in r36652) into the middle of the IWebViewPrivate interface, which changes the IWebViewPrivate vtable that Safari 3.2 relies on.
Comment 4 Adam Roben (:aroben) 2008-11-13 20:28:12 PST
Created attachment 25155 [details]
Patch + ChangeLog
Comment 5 Adam Roben (:aroben) 2008-11-13 20:30:33 PST
Committed in r38385 <http://trac.webkit.org/changeset/38385>
Comment 6 Mark Rowe (bdash) 2008-11-13 22:59:40 PST
*** Bug 22252 has been marked as a duplicate of this bug. ***